Bug 1840543 - Quota chart doesn't show up in acceptable time
Summary: Quota chart doesn't show up in acceptable time
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1845125
TreeView+ depends on / blocked
 
Reported: 2020-05-27 07:55 UTC by Yanping Zhang
Modified: 2020-10-27 16:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
quota-detail (75.58 KB, image/png)
2020-05-27 07:55 UTC, Yanping Zhang
no flags Details
quota-on-project-overview-page (88.51 KB, image/png)
2020-05-28 07:29 UTC, Yanping Zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5622 0 None closed Bug 1840543: fix bug where quota gauge chart does not appear 2020-07-22 00:04:44 UTC
Github openshift console pull 5642 0 None closed Bug 1840543: Use undefined as default value for width hook 2020-07-22 00:04:44 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:51 UTC

Description Yanping Zhang 2020-05-27 07:55:10 UTC
Created attachment 1692591 [details]
quota-detail

Description of problem:
Create quota in project, and create pod to consume some quota, go to the quota detail page, chart under "Resource Quota Details" doesn't show up for a long time.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-26-193830

How reproducible:
Always

Steps to Reproduce:
1.Create quota in project. eg:
apiVersion: v1
kind: ResourceQuota
metadata:
  name: example
  namespace: prozyp
spec:
  hard:
    pods: '4'
    requests.cpu: '1'
    requests.memory: 1Gi
    limits.cpu: '2'
    limits.memory: 2Gi
2.Create pod in the project. eg:
apiVersion: v1
kind: Pod
metadata:
  name: examplepod
  labels:
    app: hello-openshift
  namespace: prozyp
spec:
  containers:
    - name: hello-openshift
      image: openshift/hello-openshift
      ports:
        - containerPort: 8080
      resources:
        limits: 
          memory: 256Mi
          cpu: 1
3.Go to the quota detail page, check chart under "Resource Quota Details".

Actual results:
3. There is no chart shown up for a long time (I waited at least 20 seconds). After refresh the page, still need wait for some time to see the charts.

Expected results:
3. Should show charts in acceptable time and no need to refresh the page.

Additional info:

Comment 1 Yanping Zhang 2020-05-28 07:29:03 UTC
Charts under "Resource Quotas" on project overview page also has this issue, they don't show up for a long time.

Comment 2 Yanping Zhang 2020-05-28 07:29:48 UTC
Created attachment 1692938 [details]
quota-on-project-overview-page

Comment 3 Robb Hamilton 2020-05-28 13:15:16 UTC
This is a render bug.  The chart doesn't get rendered properly.  Resizing the browser forces a re-render.

Comment 4 Robb Hamilton 2020-05-28 20:01:13 UTC
PR opened, waiting for 4.6.

Comment 7 Yanping Zhang 2020-06-04 09:50:35 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.ci-2020-06-04-011434.
1. Create quota in project, and create pod to consume resource. 
2. Go to the quota detail page, check the quota chart, it shows up quickly.
3. Go to the project overview page, check the quota chart, it shows up quickly.
The bug is fixed.

Comment 9 errata-xmlrpc 2020-10-27 16:01:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.