Bug 1840594 - Fallback icon not shown on the catalog > Instantiate Template screen
Summary: Fallback icon not shown on the catalog > Instantiate Template screen
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Christoph Jerolimov
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-05-27 09:50 UTC by Christoph Jerolimov
Modified: 2020-10-27 16:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fallback icon shown on the catalog > Instantiate Template screen (58.20 KB, image/png)
2020-06-22 12:42 UTC, spathak@redhat.com
no flags Details
Fallback icon shown on the catalog > Instantiate Template screen-1 (32.98 KB, image/png)
2020-06-22 12:45 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5587 0 None closed Bug 1840594: Add fallback icon also to the "Instantiate Template" 2020-10-07 20:45:26 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:21 UTC

Description Christoph Jerolimov 2020-05-27 09:50:50 UTC
Description of problem:
After fixing https://bugzilla.redhat.com/show_bug.cgi?id=1832609 we noticed that the fallback icon was shown on the next screen ("Instantiate Template").

Version-Release number of selected component (if applicable):
4.4 and 4.5 nightly

How reproducible:
Always

Steps to Reproduce:
As described in https://bugzilla.redhat.com/show_bug.cgi?id=1832609 by Sergio:

1. Create a template without any icon information (no metadata.annotations.iconClass)
2. Find the template in the catalog and see how the icon is not shown
3. Click on the template to see the details and see how the icon is properly shown
Click on "instantiate template" and see how the icon is properly shown in the next screen

I recommend to create a project first and import then the template files with `oc create -f template-test.yaml -n yourProject`. I uploaded 3 template files to the other bugzilla issue.

Actual results:
No icon was shown, in the case that no metadata.annotations.iconClass was provied. (test case 3)

Expected results:
The same icon (fallback icon) should be shown similar to the screens before.

Additional info:

Comment 3 spathak@redhat.com 2020-06-22 12:42:08 UTC
Created attachment 1698292 [details]
Fallback icon shown on the catalog > Instantiate Template screen

Comment 4 spathak@redhat.com 2020-06-22 12:45:27 UTC
Created attachment 1698293 [details]
Fallback icon shown on the catalog > Instantiate Template screen-1

Comment 5 spathak@redhat.com 2020-06-22 13:01:07 UTC
Validated on build version: 4.6.0-0.ci-2020-06-21-102938
Browser version: Chrome76

Comment 7 errata-xmlrpc 2020-10-27 16:01:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.