Bug 184061 - Comment out unbuilt, deprecated cdda module from default-modules.conf
Summary: Comment out unbuilt, deprecated cdda module from default-modules.conf
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
: 137250 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-05 19:28 UTC by John Thacker
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-22 03:24:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Thacker 2006-03-05 19:28:16 UTC
Description of problem:
We don't ship the CDDA module with gnome-vfs2.  The module itself is deprecated,
so that's ok, but it's still enabled in
/etc/gnome-vfs-2.0/modules/default-modules.conf
This causes various errors like
(evince:17787): libgnomevfs-WARNING **: Cannot load module
`/usr/lib/gnome-vfs-2.0/modules/libcdda.so'
(/usr/lib/gnome-vfs-2.0/modules/libcdda.so: cannot open shared object file: No
such file or directory)
to spew on the console when using applications which call gnome-vfs2

Version-Release number of selected component (if applicable):
gnome-vfs2-2.13.92-3

How reproducible:
Happens fairly often, can be forced

Steps to Reproduce:
1. Insert an audio disc
2. Start gedit or evince
3. Try to open the audio disc
  
Actual results:
Warnings spewed to console

Expected results:
A more informative error message

Additional info:
The warnings are occasionally spewed without explicitly trying to open an audio
disc, such as when a directory is scanned.  Trying to open the disc directly is
the easiest way to guarantee that the message appears.  Commenting out the cdda:
line in /etc/gnome-vfs-2.0/modules/default-modules.conf fixes it.

Comment 1 John Thacker 2006-03-05 19:30:33 UTC
*** Bug 137250 has been marked as a duplicate of this bug. ***

Comment 2 John Thacker 2006-04-22 03:24:23 UTC
This finally got fixed upstream in an appropriate way (removed from
default-modules.conf, cdda-module.conf is only included if cdda is built.)

It'll get in with FC6, so it's no big deal.


Note You need to log in before you can comment on or make changes to this bug.