Bug 1840706 - When clicking add capacity action button the dropdown disappears
Summary: When clicking add capacity action button the dropdown disappears
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1852800 (view as bug list)
Depends On:
Blocks: 1842717
TreeView+ depends on / blocked
 
Reported: 2020-05-27 13:07 UTC by Itzhak
Modified: 2020-10-27 16:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the action menu to the right of operand lists could close immediately after opening. This could be seen on the Installed Operators details page when clicking one of the tabs for the operator provided APIs. The menu now functions correctly and will no longer close without user interaction.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:01:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
add capacity kebab action (28.96 KB, image/png)
2020-05-27 13:07 UTC, Itzhak
no flags Details
When clicking on add capacity kebab action the dropdown list disappeared (423.16 KB, video/webm)
2020-05-27 14:09 UTC, Itzhak
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5632 0 None closed Bug 1840706: Prevent OLM tab component unmounting every render 2020-08-06 09:39:53 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:01:21 UTC

Description Itzhak 2020-05-27 13:07:30 UTC
Created attachment 1692696 [details]
add capacity kebab action

Description of problem:
When clicking the 'add capacity' kebab action button, the dropdown list containing the 'Add capacity' option disappeared after 2 seconds what makes it very inconvenient for the user.

Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
Install OCS and create a storage cluster

Steps to Reproduce:
1. Go to Storage cluster instance page.
2. Click on add capacity kebab action.

Actual results:
The dropdown list containing the 'Add capacity' option disappears after 2 seconds.

Expected results:
The dropdown list containing the 'Add capacity' option should not disappear.

Additional info:

$oc version:
Client Version: 4.3.8
Server Version: 4.5.0-0.nightly-2020-05-27-023514
Kubernetes Version: v1.18.2+9835af5

$oc get csv -n openshift-storage:
NAME                            DISPLAY                       VERSION        REPLACES              PHASE
awss3operator.1.0.1             AWS S3 Operator               1.0.1          awss3operator.1.0.0   Succeeded
lib-bucket-provisioner.v1.0.0   lib-bucket-provisioner        1.0.0                                Succeeded
ocs-operator.v4.5.0-435.ci      OpenShift Container Storage   4.5.0-435.ci                         Succeeded

Rook version:
rook: 4.5-15.741ed813.release_4.5
go: go1.13.4

Ceph version:
ceph version 14.2.8-56.el8cp (8d24dfe40524f948afd782e14dc63a0d0cacb28b) nautilus (stable)

Comment 1 Itzhak 2020-05-27 14:09:39 UTC
Created attachment 1692715 [details]
When clicking on add capacity kebab action the dropdown list disappeared

Comment 2 Nishanth Thomas 2020-05-29 13:49:39 UTC
Looks like a core component issue, rather than to be handled by us, Moving to mgmt console.

Comment 3 Robb Hamilton 2020-05-29 18:43:04 UTC
I suspect what is happening here is a parent node is repeatedly re-rendering.  Need to investigate further.

Comment 4 Robb Hamilton 2020-05-29 20:27:24 UTC
Sam is investigating and will follow up next sprint.

Comment 5 Samuel Padgett 2020-05-29 20:30:48 UTC
I believe this anonymous component declaration is causing an unmount/remount every render.

https://github.com/openshift/console/blob/master/frontend/packages/operator-lifecycle-manager/src/components/clusterserviceversion.tsx#L983-L992

Comment 6 Samuel Padgett 2020-05-29 21:16:06 UTC
Fix in https://github.com/openshift/console/pull/5632

Comment 9 Yanping Zhang 2020-06-04 09:18:47 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.ci-2020-06-04-011434.
1. Install OCS and create a storage cluster
2. Go to Storage cluster instance page.
3. Click on add capacity kebab action. Could open the model successfully and the model doesn't disappear.
The bug is fixed.

Comment 10 Kanika Murarka 2020-07-02 07:07:40 UTC
*** Bug 1852800 has been marked as a duplicate of this bug. ***

Comment 12 errata-xmlrpc 2020-10-27 16:01:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.