Bug 1842717 - When clicking add capacity action button the dropdown disappears
Summary: When clicking add capacity action button the dropdown disappears
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1861136 (view as bug list)
Depends On: 1840706
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-01 22:47 UTC by OpenShift BugZilla Robot
Modified: 2020-07-30 18:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the action menu to the right of operand lists could close immediately after opening. This could be seen on the Installed Operators details page when clicking one of the tabs for the operator provided APIs. The menu now functions correctly and will no longer close without user interaction.
Clone Of:
Environment:
Last Closed: 2020-07-30 18:56:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
issue screenshot (193.37 KB, image/png)
2020-07-23 06:30 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5643 None closed [release-4.5] Bug 1842717: Prevent OLM tab component unmounting every render 2020-08-20 20:54:10 UTC
Red Hat Product Errata RHBA-2020:3028 None None None 2020-07-30 18:57:18 UTC

Description OpenShift BugZilla Robot 2020-06-01 22:47:58 UTC
+++ This bug was initially created as a clone of Bug #1840706 +++

Created attachment 1692696 [details]
add capacity kebab action

Description of problem:
When clicking the 'add capacity' kebab action button, the dropdown list containing the 'Add capacity' option disappeared after 2 seconds what makes it very inconvenient for the user.

Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
Install OCS and create a storage cluster

Steps to Reproduce:
1. Go to Storage cluster instance page.
2. Click on add capacity kebab action.

Actual results:
The dropdown list containing the 'Add capacity' option disappears after 2 seconds.

Expected results:
The dropdown list containing the 'Add capacity' option should not disappear.

Additional info:

$oc version:
Client Version: 4.3.8
Server Version: 4.5.0-0.nightly-2020-05-27-023514
Kubernetes Version: v1.18.2+9835af5

$oc get csv -n openshift-storage:
NAME                            DISPLAY                       VERSION        REPLACES              PHASE
awss3operator.1.0.1             AWS S3 Operator               1.0.1          awss3operator.1.0.0   Succeeded
lib-bucket-provisioner.v1.0.0   lib-bucket-provisioner        1.0.0                                Succeeded
ocs-operator.v4.5.0-435.ci      OpenShift Container Storage   4.5.0-435.ci                         Succeeded

Rook version:
rook: 4.5-15.741ed813.release_4.5
go: go1.13.4

Ceph version:
ceph version 14.2.8-56.el8cp (8d24dfe40524f948afd782e14dc63a0d0cacb28b) nautilus (stable)

--- Additional comment from ikave@redhat.com on 2020-05-27 14:09:39 UTC ---

Created attachment 1692715 [details]
When clicking on add capacity kebab action the dropdown list disappeared

--- Additional comment from nthomas@redhat.com on 2020-05-29 13:49:39 UTC ---

Looks like a core component issue, rather than to be handled by us, Moving to mgmt console.

--- Additional comment from rhamilto@redhat.com on 2020-05-29 18:43:04 UTC ---

I suspect what is happening here is a parent node is repeatedly re-rendering.  Need to investigate further.

--- Additional comment from rhamilto@redhat.com on 2020-05-29 20:27:24 UTC ---

Sam is investigating and will follow up next sprint.

--- Additional comment from spadgett@redhat.com on 2020-05-29 20:30:48 UTC ---

I believe this anonymous component declaration is causing an unmount/remount every render.

https://github.com/openshift/console/blob/master/frontend/packages/operator-lifecycle-manager/src/components/clusterserviceversion.tsx#L983-L992

--- Additional comment from spadgett@redhat.com on 2020-05-29 21:16:06 UTC ---

Fix in https://github.com/openshift/console/pull/5632

Comment 5 XiaochuanWang 2020-07-23 06:30:28 UTC
Created attachment 1702161 [details]
issue screenshot

Comment 9 Bipul Adhikari 2020-07-30 14:24:02 UTC
*** Bug 1861136 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2020-07-30 18:56:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3028


Note You need to log in before you can comment on or make changes to this bug.