Bug 184099 - Kernel panic on first boot using SMP / SATA RAID
Kernel panic on first boot using SMP / SATA RAID
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-06 05:00 EST by anshul nigham
Modified: 2015-01-04 17:25 EST (History)
4 users (show)

See Also:
Fixed In Version: 5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-24 18:20:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anshul nigham 2006-03-06 05:00:06 EST
Description of problem:
I'm trying to install FC5t3 on a Dell Dimension system that has 2 x 160 GB hard
drives in a SATA RAID0 array. anaconda detects the array as a drive and allows
partitioning of the same. Installation proceeds as normal, including formatting
of the various partitions. However, as soon as I reboot, I get a kernel panic.
The last few lines are as follows (the 'isw_cfjhhccfg_ARRAY' device was what the
installer detected as the RAID drive):

device-mapper: 4.5.0-ioctl (2005-10-04) initialised: dm-devel@redhat.com
Unable to access resume device (LABEL=swap-isw_cfjhhc)
mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Unable to make device node for 'isw_cfjhhccfg_ARRAY'
Kernel panic - not syncing: Attempted to kill init!
 [<c012310a>] panic+0x3e/0x174     [<c01261a8>] do_exit+0x71/0x6fc
 [<c01268b7>] sys_exit_group+0x0/0xd     [<c0103d39>] syscall_call+0x7/0xb

Version-Release number of selected component (if applicable):
2.6.15-1.1955_FC5smp

How reproducible:
Always

Steps to Reproduce:
1. Install FC5test3
2. Reboot after installation
3. Kernel panic pops up
  
Actual results:
As above

Expected results:
Should boot into Fedora

Additional info:
Hardware (CPU/Motherboard Info taken from CPU-Z under Windows):
CPU - Intel Pentium D 830 (Smithfield, LGA775)
Mainboard - Dell 0YC523 (Intel i945P/PL chipset, 82801GB (ICH7) Southbridge)
Drives - 2 x 160 GB SATA drives configured as RAID0 through onboard SATA RAID
controller

FC5test3 did not install a non-SMP kernel (I don't know where to specify this)
so I could not try that out.

I am trying to dual-boot with WinXP on this machine. GRUB loads fine and allows
me to boot into Windows without problems.
Comment 1 Dave Jones 2006-03-06 12:58:16 EST
Peter, mkinitrd bug ?
Comment 2 Charles 2006-03-16 08:38:25 EST
Hope this helps
I have the exact same problem with the following hardware :
CPU : Intel Petnium D820+  (LGA775)
Mainboard : Asus P5LD2 (Intel i945P + Intel ICH7R)
Drives : 2 x 200GB SATA drives configures as RAID1 through onboard SATA RAID controller

Win XP installs and works fine (although not recognizing the fake raid device as FC5 does).
Knoppix runs fine.

As for mkinitrd, I did the following (see: http://www.fedoraforum.org/forum/archive/index.php/
t-96108.html) : 
network update of mkinitrd to version 5.0.32
Built a new boot image
Replaced the existing one with the new one

On reboot I still get the same kernel panic.

I reconfigured grub adapting instructions at the end of this page  (http://tienstra4.flatnet.tudelft.nl/
~gerte/gen2dmraid/)  => still get the panic
Comment 3 anshul nigham 2006-03-30 02:20:45 EST
I reinstalled using the bordeaux DVD, and it works! Maybe it was a kernel bug?
Comment 4 anshul nigham 2006-03-30 06:00:49 EST
OK, with the stock kernel-smp=2.6.15-1.2054_FC5, everything works. A yum update
installs kernel-smp-2.6.16_1.2080_FC5, which once again breaks functionality and
causes kernel panic on bootup. The old stock kernel works.
Comment 5 Dave Jones 2006-10-16 17:32:36 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Dave Jones 2006-11-24 18:20:32 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.