Bug 1841003 - validate GIT url w/ server as the user types
Summary: validate GIT url w/ server as the user types
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Aritra Roy
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1855741
TreeView+ depends on / blocked
 
Reported: 2020-05-28 06:18 UTC by Aritra Roy
Modified: 2020-10-27 16:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1855741 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:01:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
git url validation as user types (415.65 KB, image/gif)
2020-05-28 06:18 UTC, Aritra Roy
no flags Details
validate GIT url w/ server as the user types-1 (23.02 KB, image/png)
2020-06-23 22:52 UTC, spathak@redhat.com
no flags Details
validate GIT url w/ server as the user types (22.76 KB, image/png)
2020-06-23 23:01 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5613 0 None closed Bug 1841003: fix git url validation 2020-10-28 18:30:13 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:02:19 UTC

Description Aritra Roy 2020-05-28 06:18:20 UTC
Created attachment 1692932 [details]
git url validation as user types

Description of problem:
As a user of modern webapps, it is expected to receive instant feedback. As the user enters their git URL in the import flows, they expect their input validated right away. Currently it is only validated on blur.

Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-05-27-202943

How reproducible:
always

Steps to Reproduce:
1.go to +Add page
2.select From Git
3.type in the github link in the Git Repo URL field

Actual results:
git repo is not validated as user types

Expected results:
git repo should be validated as user types

Additional info:

Comment 3 spathak@redhat.com 2020-06-23 22:52:04 UTC
Created attachment 1698510 [details]
validate GIT url w/ server as the user types-1

Comment 4 spathak@redhat.com 2020-06-23 23:01:55 UTC
Created attachment 1698512 [details]
validate GIT url w/ server as the user types

Comment 5 spathak@redhat.com 2020-06-23 23:05:34 UTC
Validated on build version: 4.6.0-0.nightly-2020-06-23-093311
Browser version: Chrome76

Comment 7 errata-xmlrpc 2020-10-27 16:01:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.