Bug 184107 - Deleted appointment still showing in Evolution
Deleted appointment still showing in Evolution
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Desktop, Reopened
: 184108 (view as bug list)
Depends On:
Blocks: 198694
  Show dependency treegraph
 
Reported: 2006-03-06 07:51 EST by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 16:55:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of "gconftool-2 --dump /apps/evolution" (27.63 KB, text/plain)
2006-07-21 14:16 EDT, Brad Hinson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 313045 None None None Never
GNOME Desktop 316495 None None None Never
GNOME Desktop 334373 None None None Never
GNOME Desktop 337023 None None None Never

  None (edit)
Description Bastien Nocera 2006-03-06 07:51:55 EST
Description of problem:
An appointment on an Exchange calendar server, deleted with Outlook, still shows
up in the Evolution calendar.

Version-Release number of selected component (if applicable):
evolution-connector-2.0.2-5

How reproducible:
Every time

Steps to Reproduce:
1. Open Evolution.
2. Open Outlook 2003
3. In Evolution, click on the “Calendar” tab.
4. Double-click in any open time frame.
5. In the time frame, enter basic meeting information. Include a reminder.
6. Click on the “Mail” tab to switch out of “Calendar” view.
7. Go over to Outlook. Click on the “Calendar” tab.
8. Single-right-click on the newly entered meeting. Scroll down to “X Delete”
and delete it.
9. Go back over to Evolution. Click on the “Calendar” tab. The appointment is
still there. The appointment is also still there after Evolution has been restarted.

Actual results:
Appointment is still there

Expected results:
Appointment has been deleted

Additional info:
Outlook 2003 SP1, and Exchange 2003 SP1 were used on the Windows side.
Comment 1 Bastien Nocera 2006-03-06 07:53:35 EST
*** Bug 184108 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2006-07-20 12:01:34 EDT
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.
Comment 5 Bastien Nocera 2006-07-20 12:06:12 EDT
Don't close my issues unless you're the developer.
Comment 6 Brad Hinson 2006-07-21 14:16:47 EDT
Created attachment 132832 [details]
output of "gconftool-2 --dump /apps/evolution"
Comment 8 Matthew Barnes 2006-08-04 13:15:48 EDT
I can confirm most of this bug, although I was using OWA instead of Outlook
2003.  I cannot confirm the last part of step 9: when I restart Evolution it
seems to update the calendar properly for me.  The deleted appointment is gone.

This bug may be much broader than what the problem description states. 
Evolution does not seem to pick up on _any_ remote updates to the appointment;
whether deleting it, moving the time, changing the location, etc.  Clicking the
"Send / Receive" button seems to have no effect, and I cannot find any other
means to force Evolution to refetch the calendar information.
Comment 9 Matthew Barnes 2006-08-04 13:23:30 EDT
This issue does not exist in evolution-connector-2.7.4.  Evolution sees all of
my updates to the appointment as soon as I make them from OWA.  It also sees
when I delete the appointment.

I will scour the upstream bug reports and see if I can locate the bug number(s)
that fixed this.  There may be patches that I can backport.
Comment 10 RHEL Product and Program Management 2006-08-18 12:33:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 11 Brad Hinson 2006-09-13 15:35:23 EDT
Matthew,

Any word on comment 9?  Wondering if this can get devel ack.

Thanks
Comment 12 Matthew Barnes 2006-09-13 17:00:49 EDT
No, I'm afraid I haven't looked at this further.

Bugzilla isn't granting me permission to devel ack this for some reason, but
I'll put it on my list of bugs to investigate further.
Comment 13 Matthew Barnes 2006-09-13 17:07:21 EDT
Oh, apparently I do have permission now.

devel ack
Comment 16 Matthew Barnes 2006-10-02 18:22:34 EDT
I found a couple of upstream bug reports that may be relevant, but I've not
found any patches.  It appears this issue was resolved in the 2.5 development cycle.

http://bugzilla.gnome.org/show_bug.cgi?id=313045
http://bugzilla.gnome.org/show_bug.cgi?id=316495

I will continue to search.
Comment 18 Matthew Barnes 2006-10-25 15:51:20 EDT
No update yet, I spent most of the day drilling into bug #199751.
Comment 30 Matthew Barnes 2007-07-31 16:55:13 EDT
We believe this bug will be fixed in the Evolution 2.8 upgrade option scheduled
for RHEL 4.6.  Please feel free to reopen this bug report if the problem still
exists in Evolution 2.8.

Note You need to log in before you can comment on or make changes to this bug.