Bug 184111 - shutdown -hy 0 fails to power off
shutdown -hy 0 fails to power off
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-03-06 09:04 EST by Dave Burgess
Modified: 2015-01-04 17:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-24 18:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Burgess 2006-03-06 09:04:31 EST
Description of problem: Halting FC5T3 doesn't power off the computer.

Version-Release number of selected component (if applicable):

All FC5T3 kernels

How reproducible: Every time.

Steps to Reproduce:
1. Select "Halt" from the system menu or open a terminal and as root enter
"shutdown -hy 0"
2. The system goes through all step properly and then sits there saying "Power Off"
Actual results:  Sits there saying "Power Off"

Expected results: It should have powered off my computer.

Additional info:  It's not a BIOS setting, those are fine I haven't changed
them.  I have removable harddrives and if I put my FC4 drive back in it works
just fine.  I've tried setting "apci=on" but that has no effect.
Comment 1 Dave Burgess 2006-03-09 07:06:51 EST
I should have specified my kernel

It's the Xen Hypervisor kernel 2.6.15-1.2009.4.2

Still doesn't power off with all updates as of 1200 UTC Thursday March 9th 2006.
Comment 2 Tomasz Kepczynski 2006-03-26 10:43:25 EST
I have the same problem. Poweroff from kdm does not work, ie. system
is stopped but not turned off. I have to push big button on PC for quite
some time.
Now what's strange is that after what's described above I cannot power-up
from keyboard (windows 98 power-up key option in BIOS).
All of this happens with xen and hypervisor kernel. Standard kernel does not
cause this problem.
Platform is x86_64 with Athlon and Gigabyte motherboard.
Comment 3 stef 2006-04-01 10:39:44 EST
same Pb for me too but I have a quite longer history regarding this issue, see
bug #160775 and bug #180006 .

kernel, 2.6.11 , 2.6.12 , 2.6.15 and 2.6.16 from fedora breaks the power off
feature on my Tyan Tiger K8W motherboard, others kernels works fine.

To give more infos, lately I had a look at the AMI bios post codes and found
that when the power remains at the very last moment of the power-off process
(when the power should be turned off) it gives a FF code.
Wich alas seems not to be very helpfull since it would mean a hardware breakage
wich is not the case here, switching for another kernel does the right thing.

Please people involed with kernel developpement, what can we do to give you the
most accurate informations to track down this long lasting bug ?
What infos can we feed this mailling list to be accurate on what's going on at
the shutdown process ?
Comment 4 Dave Jones 2006-10-16 17:25:04 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 5 Dave Jones 2006-11-24 18:14:17 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.