Bug 184235 - Application windows opened from a terminal should open on top of the terminal window
Application windows opened from a terminal should open on top of the terminal...
Status: CLOSED DUPLICATE of bug 186308
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Depends On:
  Show dependency treegraph
Reported: 2006-03-07 11:15 EST by Uno Engborg
Modified: 2014-06-18 05:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-24 18:08:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Uno Engborg 2006-03-07 11:15:59 EST
Description of problem:

If I start a new program from a gnome terminal, the window of the new program
appears below the terminal window. This has the advantage that the new opening
program window doesn't catch keyboard intput that was intended for the terminal
but that hasn't really been a big problem in the past.

The new behavior on the other hand, really confuses users. I have tested this on
real users and in many cases thy think the command somehow failed and tries
again. It seams to be a bigger problem on small screens (e.g 1024x768) where
there is less room for the opening application, and where panels might be in
hide automatically mode to save space, making the blinking of the application in
the panel less visible.

Even in the cases where the user, knows that the application turns up below the
opening terminal, it generates more mouse work. If this is a featurre and not a
bug it should at least be possible to have some gconf key to set it back to the
old behavior.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open a gnome terminal
2. from that terminal run e.g. gedit
3. watch gedit open under the terminal
Actual results:
Application window opens under the terminal window

Expected results:
Application window opens on top of terminal window

Additional info:
Comment 1 Josh Boyer 2006-03-20 16:14:46 EST
Seems to have something to do with sloppy focus as well.
Comment 2 Steve Fox 2006-03-20 16:15:43 EST
This bug persists on FC5-final. I will need to invest in a punching bag if it is
not fixed soon. :) I am also using sloppy focus.
Comment 3 Rahul Sundaram 2006-03-24 18:08:30 EST

*** This bug has been marked as a duplicate of 186308 ***

Note You need to log in before you can comment on or make changes to this bug.