This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 186308 - Experimental strict-focus approximation isn't intuitive
Experimental strict-focus approximation isn't intuitive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
: Reopened
: 178389 184235 188046 188967 (view as bug list)
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-03-22 15:28 EST by Dave Jones
Modified: 2015-01-04 17:26 EST (History)
17 users (show)

See Also:
Fixed In Version: metacity-2.14.3-1.fc5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-26 11:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 326159 None None None Never

  None (edit)
Description Dave Jones 2006-03-22 15:28:30 EST
1. start gnome-terminal
2. run an application that opens a window from that terminal
3. window wtf happened.
4. figure out that it's underneath the terminal window.

This is seriously driving me nuts.
Comment 1 Ray Strode [halfline] 2006-03-22 15:36:55 EST
Relevent upstream bug report:

http://bugzilla.gnome.org/show_bug.cgi?id=326159

Comment 2 Ray Strode [halfline] 2006-03-22 15:46:56 EST
I thought upstream had already commited a patch to turn this off, but it doesn't
look like it's happened yet.

Let's hold off until it does, and when it does we can push an update.
Comment 3 Rahul Sundaram 2006-03-24 18:08:50 EST
*** Bug 184235 has been marked as a duplicate of this bug. ***
Comment 4 Rahul Sundaram 2006-03-24 18:50:31 EST
*** Bug 178389 has been marked as a duplicate of this bug. ***
Comment 5 Uno Engborg 2006-03-24 21:29:04 EST
(In reply to comment #2)
> I thought upstream had already commited a patch to turn this off, but it doesn't
> look like it's happened yet.
> 
> Let's hold off until it does, and when it does we can push an update.


Once the patch arrive, please make the turned off state be the default behavior.
In some application the entire application window is covered by the terminal
window. E.g. try open sabayon. 
Comment 6 Lauri Nurmi 2006-04-01 12:59:27 EST
Seriously, if this "feature" doesn't get fixed soon -- regardless of upstream's
decisions -- I'm switching to KDE or IceWM or something else that is still usable.

Clicking URLs in gnome-terminal opens them in background. Clicking URLs in
Evolution opens them in background. I have never encountered a user interface as
painful to use as this is. A lot of unnecessary extra work is required to
Alt-Tab myself to the correct application.
Comment 7 Ron Yorston 2006-04-02 04:36:54 EDT
I've been working on the upstream patch to make this behaviour configurable.  A
pre-release version of metacity with the patch applied is available here:

   http://intgat.tigress.co.uk/rmy/metacity/fc5.html
Comment 8 Rahul Sundaram 2006-04-09 14:21:01 EDT
*** Bug 188046 has been marked as a duplicate of this bug. ***
Comment 9 Stuart Jansen 2006-04-11 18:45:17 EDT
I spend most of my day on the command line. This bug is driving me crazy, and
I've only been using FC5 for about 12 hours. Repeatedly coaxing forward windows
hiding behind my terminal is really hurting my productivity. I'd prefer not to
wait for upstream to fix the problem. Please, make the hurting stop.

Ron: Many thanks for your patched RPM, it has made my desktop usable again.
Sadly, I now live in fear of a yum update bringing back the old behavior.
Comment 10 Elijah Newren 2006-04-12 13:58:01 EDT
I'd suggest using Ron's patch in upstream #326159.  It's been applied to
upstream cvs head.  It'll only make it into the upstream gnome-2-14 cvs branch
if the release team approves the freeze break (which is pending, but possibly
unlikely).
Comment 11 Ray Strode [halfline] 2006-04-12 16:02:52 EDT
Sounds good.

Thanks Elijah.
Comment 12 Ignacio Vazquez-Abrams 2006-04-13 19:49:05 EDT
*** Bug 188967 has been marked as a duplicate of this bug. ***
Comment 13 Matthias Clasen 2006-04-19 00:15:03 EDT
I believe the focus-mode gconf key is in metacity 2.14.1, which is in FC5 by now.
Comment 14 Paul Dickson 2006-04-19 05:06:05 EDT
I originally reported this as Bug 178389 against devel. (Closed as duplicate in
comment 4.) The problem still appears to exists in devel with metacity-2.15.0-5.
Comment 15 Dave Jones 2006-04-24 23:33:33 EDT
indeed, this still bites in current FC5+updates as well as rawhide, and this
should really be default rather than force everyone to go fishing for gconf keys.
Comment 16 Ron Yorston 2006-04-25 04:59:17 EDT
I don't know about rawhide:  maybe someone needs to pull in a newer version from
upstream.  But FC5+updates should be OK.  The current version of metacity for
FC5 is 2.14.3-1.fc5.1, and that certainly does include my patch.  (The Bugzilla
'Fixed in' field is incorrect:  the patch was first introduced in
2.14.2-1.fc5.2, but that never made it out of updates-testing.)

The patch turns off the experimental strict-focus approximation behaviour by
default.  The only people who need to worry about gconf keys are those who want
it turned on.
Comment 17 Søren Sandmann Pedersen 2006-04-26 11:03:59 EDT
This really is supposed to be fixed in both fc5+updates and rawhide. Feel free
to repopen if it isn't.

Note You need to log in before you can comment on or make changes to this bug.