Bug 184253 - Pirut immediately fails with No Attribute GroupError
Pirut immediately fails with No Attribute GroupError
Status: CLOSED DUPLICATE of bug 181370
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 13:42 EST by Walter Francis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:57:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Walter Francis 2006-03-07 13:42:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
When attempting to run Pirut from Gnome or command line, it immediately fails for No Attribute GroupError in the blurb of Python that is barfed out.

Component: Software Manager
Summary: TBf0b8122f __init__.py:135:reposSetup:AttributeError: 'module' object has no attribute 'GroupError'

Traceback (most recent call last):
File "/usr/sbin/pirut", line 404, in ?
main()
File "/usr/sbin/pirut", line 400, in main
pm.run()
File "/usr/sbin/pirut", line 350, in run
self.doRefresh()
File "/usr/sbin/pirut", line 360, in doRefresh
self.reposSetup(pbar)
File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 135, in reposSetup
except yum.Errors.GroupError:
AttributeError: 'module' object has no attribute 'GroupError'

Local variables in innermost frame:
callback: <pirut.Progress.PirutProgressCallback instance at 0x2b6ddf80ed88>
self: <__main__.PackageManager object at 0x2b6ddf4c8290>

Version-Release number of selected component (if applicable):
0.9.10-1

How reproducible:
Always

Steps to Reproduce:
1. Install FC5t3
2. Use yum, see that it works.
3. Launch Pirut, note that it fails for GroupInfo something.

Actual Results:  Pirut fails.

Expected Results:  Pirut launches and is able to install/remove software.

Additional info:
Comment 1 Jef Spaleta 2006-03-07 13:57:53 EST
Closing this as duplicate of bug 181370
and fixed in pirut 0.9.11-1

Please before filing bugs, check to see if the latest available update has fixed
the issue.


*** This bug has been marked as a duplicate of 181370 ***
Comment 2 Walter Francis 2006-03-22 16:14:31 EST
Yes, is it is fixed in x86_64 FC5 DVD release.

Note You need to log in before you can comment on or make changes to this bug.