Bug 181370 - Package Updater fails while retrieving update information
Package Updater fails while retrieving update information
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 181431 181724 181733 184253 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-13 13:42 EST by Chris Negus
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-13 13:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Negus 2006-02-13 13:42:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Opened the Package Updater window (Applications -> System Tools -> Software Updater) and as it was retrieving update information an "Exception Occurred" pop-up appeared with the following information:

-----------------
Component: Software Updater
Summary: TBf0b8122f __init__.py:135:reposSetup:AttributeError: 'module' object has no attribute 'GroupError'

Traceback (most recent call last):
  File "/usr/sbin/pup", line 356, in ?
    main()
  File "/usr/sbin/pup", line 352, in main
    pup.run()
  File "/usr/sbin/pup", line 328, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 160, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 135, in reposSetup
    except yum.Errors.GroupError:
AttributeError: 'module' object has no attribute 'GroupError'

Local variables in innermost frame:
callback: <pirut.Progress.PirutProgressCallback instance at 0xb7a1eb8c>
self: <__main__.PackageUpdater object at 0xb79f618c>
---------------------
After closing the exception window, Package Updater exited. (By the way, you might consider having the same menu and title name. The menu says Software Updater and window says Package Updater.)


Version-Release number of selected component (if applicable):
pirut-0.9.10-1

How reproducible:
Always

Steps to Reproduce:
1. From GNOME, select Applications -> System Tools -> Software Updater
2. Exception occurs while retrieving update information
3.
  

Actual Results:  After saving exception output, Software Updater closes.

Expected Results:  Should continue on to gather software update information.

Additional info:

My system was rebooted by mistake during an update. I ended up having both pirut-0.9.10-1 and pirut-0.9.8-1 installed at the same time. I removed the older package and rebooted, but the same error occurred.
Comment 1 Jeremy Katz 2006-02-13 13:49:57 EST
Hit this earlier and fixed in cvs.  yum update yum first will fix -- it's caused
by the group file syntax changing a little and the group code in yum not being
that forgiving (+ a typo in pup :)
Comment 2 Paul Nasrat 2006-02-13 17:50:59 EST
*** Bug 181431 has been marked as a duplicate of this bug. ***
Comment 3 Jim Cornette 2006-02-14 06:44:30 EST
I am able to use pup with a smaller update transaction. I also updated [a-f],
[h-m] then [n-z] yesterday with yum directly. This morning was with new updates
pushed and packages in the g range from yesterday's update.
Reporting in from bug 181431 which was marked as duplicate of this bug.
Comment 4 Jeremy Katz 2006-02-15 19:39:34 EST
*** Bug 181724 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2006-02-15 22:21:11 EST
*** Bug 181733 has been marked as a duplicate of this bug. ***
Comment 6 Jef Spaleta 2006-03-07 13:58:06 EST
*** Bug 184253 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.