Bug 184292 - (FC4->FC5 Anaconda Upgrade) scim-libs upgraded before pango
(FC4->FC5 Anaconda Upgrade) scim-libs upgraded before pango
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: i18n
: 187261 (view as bug list)
Depends On:
Blocks: 171491 FC6Blocker
  Show dependency treegraph
 
Reported: 2006-03-07 15:52 EST by Warren Togami
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-28 04:46:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log (36.26 KB, text/plain)
2006-03-07 16:00 EST, Warren Togami
no flags Details
Ordering from a fc4 system (2.00 MB, text/plain)
2006-03-08 13:51 EST, Paul Nasrat
no flags Details

  None (edit)
Description Warren Togami 2006-03-07 15:52:59 EST
FC4 anaconda upgrade into rawhide-20060307 has a scriptlet error when it runs
%post of scim-libs.  The PreReq listed below should be DTRT but somehow fails in
the anaconda upgrade case.  A fresh install of rawhide-20060307 installs in the
correct order.

scim.spec contains:
===================
%package libs
Summary:    Smart Common Input Method libraries
Group:      System Environment/Libraries
# for update-gtk-immodules
PreReq:     gtk2 > 2.8
Obsoletes:  iiimf-libs <= 1:12.2

%post libs
/sbin/ldconfig
%{_bindir}/update-gtk-immodules %{_target_platfo

upgrade.log 37%:
================
Upgrading scim-libs-1.4.4-9.i386.
Cannot load module /usr/lib/gtk-2.0/immodules/im-scim.so:
libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory
/usr/lib/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API:
libpangocairo-1.0.so.0: cannot open shared object file: No such file or directory
error: %post(scim-libs-1.4.4-9.i386) scriptlet failed, exit status 1

upgrade.log 48%:
================
Upgrading pango-1.11.99-1.i386.
upgrade.log 49%:
================
Upgrading gtk2-2.8.13-3.i386.
Comment 1 Warren Togami 2006-03-07 16:00:42 EST
Created attachment 125777 [details]
upgrade.log

Example upgrade.log
Comment 2 Paul Nasrat 2006-03-08 13:48:05 EST
Replicated both inside and outside installer.
Comment 3 Paul Nasrat 2006-03-08 13:51:13 EST
Created attachment 125828 [details]
Ordering from a fc4 system

Steps taken for attached order details:

import yum

y = yum.YumBase()

y.doConfigSetup()
y.doTsSetup()
y.doRpmDBSetup()
y.repos.disableRepo('*')
y.repos.enableRepo('local*')
y.doRepoSetup()
y.doGroupSetup()
y.doSackSetup()
y.update()
y.initActionTs()
y.populateTs()
y.ts.check()
import rpm
rpm.setVerbosity(rpm.RPMLOG_DEBUG)
y.ts.ts.order()
Comment 4 Jeff Johnson 2006-03-08 18:12:27 EST
Try adding whiteout to remove the loops.
Comment 5 Warren Togami 2006-03-08 18:20:02 EST
This is necessary even though scim-libs has a PreReq on gtk2 > 2.8, and FC4 had
gtk2-2.6?
Comment 6 Jeff Johnson 2006-03-08 18:27:35 EST
I said "Try adding whiteout to remove the loops." Did you?
Comment 7 Jens Petersen 2006-03-30 02:19:11 EST
*** Bug 187261 has been marked as a duplicate of this bug. ***
Comment 8 Jens Petersen 2006-04-06 00:50:47 EDT
Jeff, what does "whiteout" mean?  Who was that question addressed? 
Comment 9 Jeff Johnson 2006-07-07 00:04:24 EDT
My reply was to warren.

The term "whiteout" comes from typewriters, messy goo to fix typos on paper.

In this context, whiteout means breaking dependency loops at precisely one
known point between 2 package nodes, as rpm ignores all Requires: in a loop,
leading to a difficult to QA indeterminism in package ordering.

Warren should know what "whiteout" is, if not, well, he has no business asking
stupid questions.
Comment 10 Caius Chance 2006-08-28 01:45:43 EDT
Is it a yum problem in prioritizing the package installation/upgrade order?

If so, would it be appropriate to change the involved component to "yum"?
Comment 11 Jens Petersen 2006-08-28 04:46:24 EDT
AFAIR this doesn't happen for final FC5 so I think we can close this.

Note You need to log in before you can comment on or make changes to this bug.