Bug 187261 - scim-lib upgrade error
scim-lib upgrade error
Status: CLOSED DUPLICATE of bug 184292
Product: Fedora
Classification: Fedora
Component: scim (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Jens Petersen
Depends On:
  Show dependency treegraph
Reported: 2006-03-29 12:16 EST by Chris Ricker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-03-30 02:18:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2006-03-29 12:16:10 EST
anaconda upgrade from FC4 to FC5

I got this in the upgrade.log:

Upgrading scim-libs-1.4.4-9.i386.
Cannot load module /usr/lib/gtk-2.0/immodules/im-scim.so: libpangocairo-1.0.so.0
: cannot open shared object file: No such file or directory
/usr/lib/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API: libpan
gocairo-1.0.so.0: cannot open shared object file: No such file or directory
error: %post(scim-libs-1.4.4-9.i386) scriptlet failed, exit status 1
Comment 1 Jens Petersen 2006-03-30 01:58:48 EST
Hmm, that was supposed to be fixed already in 1.4.4-9 with "PreReq: gtk2 > 2.8".
Is that not sufficient?

Is this with an i386 or x86_64 install?
Comment 2 Jens Petersen 2006-03-30 02:18:54 EST

*** This bug has been marked as a duplicate of 184292 ***
Comment 3 Jens Petersen 2006-03-30 02:35:49 EST
I recommend running:

# /usr/bin/update-gtk-immodules i386-redhat-linux-gnu

after upgrading to configure the scim gtkimmodule correctly.

Note You need to log in before you can comment on or make changes to this bug.