Bug 1842965 - Operand's tab for Operand list view is missing
Summary: Operand's tab for Operand list view is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1842968
TreeView+ depends on / blocked
 
Reported: 2020-06-02 13:08 UTC by Cyril
Modified: 2020-10-27 16:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Code error Consequence: Fix: Yes Result: Works as expected
Clone Of:
: 1842968 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:03:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Operand's tab for Operand list view is missing (233.48 KB, image/png)
2020-06-02 13:08 UTC, Cyril
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5648 0 None closed Bug 1842965: - Operand's tab for Operand list view is missing 2020-09-11 13:19:59 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:04:20 UTC

Description Cyril 2020-06-02 13:08:36 UTC
Created attachment 1694454 [details]
Operand's tab for Operand list view is missing

Description of problem:Due to a missing `displayName` field of the "owned CRD" in the CSV file, Operand's tab for Operand list view is missing


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to "OperatorHub" view, installed "Red Hat Quay" Operator to any NS.
2. Go to "Red Hat Quay" Operator details view <--- Operand's tab for Operand list view is missing

Actual results:
Operand's tab for Operand list view is missing


Expected results:
The operator details page should have Operand tab for CSV without `displayName` field

Additional info:

Comment 1 Yanping Zhang 2020-06-03 07:20:26 UTC
Checked on ocp 4.6 cluster with payload 4.6.0-0.ci-2020-06-02-211434.
1. Go to "OperatorHub" view, install "Red Hat Quay" Operator to one project.
2. Go to "Red Hat Quay" Operator details view, check tabs, there are "Details","YAML","Subscription","Events","QuayEcosystem" tabs.
The bug is fixed.

Comment 4 errata-xmlrpc 2020-10-27 16:03:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.