Bug 1842968 - Operand's tab for Operand list view is missing
Summary: Operand's tab for Operand list view is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Cyril
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1842965
Blocks: 1835938
TreeView+ depends on / blocked
 
Reported: 2020-06-02 13:11 UTC by Cyril
Modified: 2020-07-30 18:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1842965
Environment:
Last Closed: 2020-07-30 18:56:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Operand's tab for Operand list view is missing (233.48 KB, image/png)
2020-06-02 13:11 UTC, Cyril
no flags Details
Verification screenshot (43.65 KB, image/png)
2020-07-23 02:08 UTC, XiaochuanWang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5653 None closed [release-4.5.z] Bug 1842968: - Operand's tab for Operand list view is missing 2020-07-29 12:27:18 UTC
Red Hat Product Errata RHBA-2020:3028 None None None 2020-07-30 18:57:18 UTC

Description Cyril 2020-06-02 13:11:53 UTC
Created attachment 1694455 [details]
Operand's tab for Operand list view is missing

+++ This bug was initially created as a clone of Bug #1842965 +++

Description of problem:Due to a missing `displayName` field of the "owned CRD" in the CSV file, Operand's tab for Operand list view is missing


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Go to "OperatorHub" view, installed "Red Hat Quay" Operator to any NS.
2. Go to "Red Hat Quay" Operator details view <--- Operand's tab for Operand list view is missing

Actual results:
Operand's tab for Operand list view is missing


Expected results:
The operator details page should have Operand tab for CSV without `displayName` field

Additional info:

Comment 5 XiaochuanWang 2020-07-23 02:08:59 UTC
Created attachment 1702146 [details]
Verification screenshot

Comment 6 XiaochuanWang 2020-07-23 02:10:57 UTC
Refer to the screenshot, this is fixed.
Verified on 4.5.0-0.nightly-2020-07-22-192425

Comment 8 errata-xmlrpc 2020-07-30 18:56:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3028


Note You need to log in before you can comment on or make changes to this bug.