Bug 184332 - anaconda consumes all memory then dies during installation
anaconda consumes all memory then dies during installation
Status: CLOSED DUPLICATE of bug 183930
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-07 19:33 EST by Lonni J Friedman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-08 01:08:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2006-03-07 19:33:33 EST
Description of problem:
On an HP xw9300 (tested with 4GB & 8GB RAM), attempts to install RHEL4-U3
(final) fail, with anaconda hanging just after the disk is formatted.  Watching
'top' I see anaconda consuming more and more memory until it finally dies with
an exception & traceback that ends with "OSError: [Errno 12] Cannot allocate memory

How reproducible:
every time

Steps to Reproduce:
1.Attempt to install RHEL4-U3
2.after disks are formatted, the installer will hang
3.
  
Actual results:
anaconda consumes all system memory, then generates an exception

Expected results:
Installation completes successfully (as it does for Update2)

Additional info:
Interestingly, the 32bit (x86) version works fine on this same system.
Comment 1 Peter Jones 2006-03-08 01:08:18 EST

*** This bug has been marked as a duplicate of 183930 ***

Note You need to log in before you can comment on or make changes to this bug.