Bug 183930 - anaconda using all available memory during an install
anaconda using all available memory during an install
Status: CLOSED DUPLICATE of bug 171930
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.3
All Linux
high Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: Regression
: 184332 190134 (view as bug list)
Depends On: 171930
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-03 15:47 EST by Chris Williams
Modified: 2007-11-30 17:07 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 15:17:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda dump from failed install (699.07 KB, text/plain)
2006-03-03 15:47 EST, Chris Williams
no flags Details
nanconda log from failed install (11.12 KB, text/plain)
2006-03-03 15:51 EST, Chris Williams
no flags Details

  None (edit)
Description Chris Williams 2006-03-03 15:47:14 EST
Description of problem: RHEL4 U3 RC3 x86_64 anaconda using all available memory
during an install


Version-Release number of selected component (if applicable):
RHEL4 U3 RC3 


How reproducible:
everytime, although using mem=512M appears to work around this


Steps to Reproduce:
1. Use RC3, RHEL4U3 x86_64
2. After selecting RPMs monitor VC2 with top, you'll see anaconda use all
available memory
3. 
  
Actual results:
Install fails with an anaconda trace back

Expected results:
Install should succeed

Additional info:
traceback:
line 1173 in ?
line 510 in run dispatch.gotoNext()
line 171 in gotoNext self.moveSetup()
line 239 in MoveStep rc=apply(func,self,bindings(args))
line 967 in doInstall syslog.start(instPath,syslogname)
line 65 in Start self.pid=os.fork()

OSError: [Errno 12} cannot allocate memory
Comment 1 Chris Williams 2006-03-03 15:47:14 EST
Created attachment 125621 [details]
anaconda dump from failed install
Comment 2 Chris Williams 2006-03-03 15:51:26 EST
Created attachment 125622 [details]
nanconda log from failed install
Comment 7 Peter Jones 2006-03-07 11:14:33 EST
I've just done a successful install on xw9300 without any workarounds.  Please
provide more info about your setup:

a) what disk controller are you using?

b) what install media (cd, dvd, nfs, http, etc)?

c) what's your partitioning layout look like?

d) are you using kickstart?  If so, please attach the ks.cfg.

e) How much memory do you have, and how much swap have you configured?
Comment 8 Peter Jones 2006-03-07 11:16:30 EST
Also, what BIOS rev are you using on the xw9300?
Comment 9 Jay Turner 2006-03-07 11:25:28 EST
HP, can you please confirm that RC2 works without fail on these boxes?  We're
trying to narrow down the possible culprit patches, but there's very little
change between RC2 and RC3 . . . really nothing to explain this change in
behavior.  Also is this failure happening 100% of the time?
Comment 10 Chris Williams 2006-03-07 11:35:52 EST
Peter,
I am currently reproducing on a xw8200. I've reproduced on a xw9300 and I'll
provide details on that asap.

Here are the details on the xw8200: 

a) what disk controller are you using?
LSI SCSI HBA 53c1030 

b) what install media (cd, dvd, nfs, http, etc)?
I am using disk 1, "linux askmethod" and I point the NFS install to the 5 ISOs

c) what's your partitioning layout look like?
I am using the default layout.

d) are you using kickstart?  If so, please attach the ks.cfg.
No, just an NFS install

e) How much memory do you have, and how much swap have you configured?
4GB installed. I am using the default layout, which is 2GB.
Comment 11 Peter Jones 2006-03-07 13:03:20 EST
jburke says it works on his xw8200.  These machines are also part of RHTS, which
hasn't recorded any failures.

Are you sure you're using the most recent BIOS, and aren't seeing any hardware
failure when this happens?
Comment 12 Jeff Burke 2006-03-07 14:15:36 EST
I have just reinstalled RHEL4-U3-RC4 x86_64 AS via disk1 then using NFS on the
xw8400 system in my cube. I have also installed RHEL4-U3-RC4 x86_64 on the
xw6200 system in my cube. 

I am running another test in RHTS with the xw9300 system. I am also looking at
the  database for the tests that were already run to triple check that it was
tested.

Chris could you try a complete cd install.
Comment 13 Chris Williams 2006-03-07 14:42:21 EST
I'll burn the CDs now.
HP reports it fails with CDs and I can reproduce the problem everytime doing
NFS-ISO istall and an install to the tree while booting from a boot.iso.
Comment 14 Jeff Burke 2006-03-07 14:53:46 EST
Ok Just verified that in fact RHTS has install RHEL4-U3-RC4 onto the xw9300.
Here is the URL for the job. Note this uses your BZ login.
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/jobs.cgi?id=4819&type=Single

Comment 15 Chris Williams 2006-03-07 15:19:11 EST
I tried a CD install but it still fails with anaconda using all available memory.
Comment 16 Jeff Burke 2006-03-07 15:39:10 EST
I have just gone back to the database and verified that RHEL4-U3-RC3 also
installed on the xw9300 in RHTS. Here is the URL.
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/jobs.cgi?id=4797&type=Single

I have also borrowed an xw9300 from the onsite AMD developer and tried to
installed RHEL4-U3-RC4 on that system **This reproduces the issue reported by
cww**. It has version 2.02 bios, Sata, and 4 GIG of ram.
Comment 17 Jeff Burke 2006-03-07 16:57:53 EST
Some additional notes: 
     Now that I have a system that reproduces the issue. I have tried the
following releases.
           1. RHEL4-U3-RC4 - Did not work
           2. RHEL4-U3-RC3 - Did not work
           3. RHEL4-U3-RC2 - Did not work
           4. RHEL4-U3-RC1 - Worked.

What does "Did not work" mean. During the install it gets to the point where it
will format the partitions. When formatting /boot it gets to about 90% and looks
to be hung. You an still move to different vty's and when you do a top. You can
see anaconda growing.  If you let it continue it will never finish teh format of
/boot. It will get an anaconda exception "out of memory type error".

Jeff
Comment 18 Peter Jones 2006-03-08 01:08:42 EST
*** Bug 184332 has been marked as a duplicate of this bug. ***
Comment 22 Jeff Bastian 2006-03-09 18:22:49 EST
I just kickstarted six systems with RHEL4 U3 (final) and all six of my systems
finished the kickstart with no problems.  I ran 'top' during the installation
and Anaconda used a max of 150MB.  I did *not* use 'mem=512M' to limit the
memory on the systems.

Here are my system types:

  System                 OS
  =========              ==================
  IBM x335,   4GB RAM     RHEL4 U3 AS x86
  IBM x335,   4GB RAM     RHEL4 U3 WS x86
  Sun V20z,  16GB RAM     RHEL4 U3 AS x86_64
  Sun V20z,  16GB RAM     RHEL4 U3 WS x86_64
  HP DL585,  64GB RAM     RHEL4 U3 AS x86_64
  HP xw4200,  2GB RAM     RHEL4 U3 WS x86_64
Comment 24 Bram Timmerarends 2006-03-10 15:55:05 EST
Our kickstarts go OK in RHEL4 U2 WS x86_64, but 
  - fail with RHEL4 U3 WS x86_64, and 
  - fail with RHEL4 U3 WS x86_64 + mem=512M option

Systems (3) are all HP xw8200, 6GB RAM BIOS v2.03, SCSI DISK

We boot with boot.iso and do an NFS-ISO install (all other options default). 

Just after formatting the root file system the Red Hat installer program seems 
to hang. Switching to vt2 and top show that the anaconda process grows (for 
15m) then crashes.
Comment 28 Peter Jones 2006-03-21 14:39:40 EST
Could you try doing an NFS install, and putting
http://people.redhat.com/pjones/anaconda-rhel4/isys.py in a directory called
"RHupdates" in the top level of the installation tree?
Comment 29 Bram Timmerarends 2006-03-22 05:56:58 EST
Peter, my colleagues Xander and Jorrit tested the three systems [previously
failing to install RHEL4u3] again with your RHupdates isys.py fix, and all
installed OK. Many thanks!
Comment 38 Eric Bennett 2006-03-31 13:13:45 EST
Thank you Peter!  I was experiencing the same issue with an xw9300 and your
isys.py fixed it.

I am using version 4 of ES x86_64, update 3, but unlike the original report I am
installing onto an SATA disk rather than SCSI.  Dual dual core 2.4 GHz, 4 GB
RAM, 2.02 BIOS, default partitioning.  I tried CD and HTTP installs before
finding this bug report.

Comment 42 Jeremy Katz 2006-05-01 15:39:24 EDT
*** Bug 190134 has been marked as a duplicate of this bug. ***
Comment 43 Karsten Weiss 2006-05-10 09:14:06 EDT
Is there also a way to work around this bug when doing an CD install?
Comment 44 Brian Sutin 2006-05-10 10:00:10 EDT
For CD install, just type in "linux mem=512M" at the boot prompt.  Works great.
By the way, this bug does not exist in RHE WS 3.
Comment 45 Brian Sutin 2006-05-10 10:02:35 EDT
For CD install, just type in "linux mem=512M" at the boot prompt.  Works great.
By the way, this bug does not exist in RHE WS 3.
Comment 46 Chris Williams 2006-05-10 10:18:17 EDT
Also, see the following Red Hat Knowledge Base article:
http://kbase.redhat.com/faq/FAQ_85_8107.shtm
Comment 51 Suzanne Yeghiayan 2006-05-30 17:27:09 EDT

*** This bug has been marked as a duplicate of 171930 ***

Note You need to log in before you can comment on or make changes to this bug.