Bug 1843374 - [sriov] Failed to generate net-att-def CR when ipam is not specified in SriovNetwork CR
Summary: [sriov] Failed to generate net-att-def CR when ipam is not specified in Sriov...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Peng Liu
QA Contact: zhaozhanqi
URL:
Whiteboard:
Depends On:
Blocks: 1859231
TreeView+ depends on / blocked
 
Reported: 2020-06-03 07:29 UTC by Peng Liu
Modified: 2020-10-27 16:05 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1859231 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:04:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 232 0 None closed BUG 1843374:Set empty ipam to net-att-def when users don't specify ipam in SriovNetwork 2020-10-26 21:38:53 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:04:59 UTC

Description Peng Liu 2020-06-03 07:29:06 UTC
Description of problem:
Failed to generate net-att-def CR when ipam is not specified in SriovNetwork CR

Version-Release number of selected component (if applicable):


How reproducible:
Create a SriovNetwork CR without specifying 'ipam'

```
apiVersion: sriovnetwork.openshift.io/v1
kind: SriovNetwork
metadata:
  name: nic2
spec:
  networkNamespace: default
  resourceName: nic2
```

Steps to Reproduce:
1.
2.
3.

Actual results:
The net-att-def CR was not generated.


Expected results:
The net-att-def CR shall be generated with empty ipam.

Additional info:

Comment 3 zhaozhanqi 2020-06-15 06:56:39 UTC
Verified this bug with images:
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.6.0-202006111517-ose-sriov-network-operator-20200615.002329
quay.io/openshift-release-dev/ocp-v4.0-art-dev:v4.6.0-202006111517-ose-sriov-network-config-daemon-20200615.002329

the net-attach-def can be created when the sriovnetwork without ipam.

Comment 5 errata-xmlrpc 2020-10-27 16:04:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.