Bug 1859231 - [4.5][sriov] Failed to generate net-att-def CR when ipam is not specified in SriovNetwork CR
Summary: [4.5][sriov] Failed to generate net-att-def CR when ipam is not specified in ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 4.5.z
Assignee: zenghui.shi
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1858223 (view as bug list)
Depends On: 1843374
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-07-21 14:00 UTC by zenghui.shi
Modified: 2020-09-08 10:54 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
If you do not specify an IPAM configuration in the SriovNetwork configuration, you must include an empty `ipam: {}` parameter or the NetworkAttachmentDefinition will not be created.
Clone Of: 1843374
Environment:
Last Closed: 2020-09-08 10:54:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift sriov-network-operator pull 309 None closed BUG 1859231: Set empty ipam to net-att-def when users don't specify ipam in SriovN… 2020-09-22 03:51:13 UTC
Red Hat Product Errata RHBA-2020:3510 None None None 2020-09-08 10:54:26 UTC

Comment 1 zenghui.shi 2020-07-21 14:04:53 UTC
*** Bug 1858223 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2020-09-08 10:54:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.