Bug 1843817 - Find_loadbalancer method should also use provider information
Summary: Find_loadbalancer method should also use provider information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.0
Assignee: Luis Tomas Bolivar
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1842466
Blocks: 1844091
TreeView+ depends on / blocked
 
Reported: 2020-06-04 08:38 UTC by OpenShift BugZilla Robot
Modified: 2020-07-13 17:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-07-13 17:43:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 263 0 None closed [release-4.5] Bug 1843817: Ensure provider information is used when finding lbs 2020-08-18 10:33:35 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:43:28 UTC

Description OpenShift BugZilla Robot 2020-06-04 08:38:52 UTC
+++ This bug was initially created as a clone of Bug #1842466 +++

Since OpenShift 4.4, kuryr support both amphora and ovn octavia loadbalancer drivers. Kuryr should differentiate existing loadbalancer depending on its provider too

Comment 5 rlobillo 2020-06-09 13:55:51 UTC
As the required conditions to match this scenario requires to perform amphora to ovn-octavia upgrade and this is still not supported, we agreed to verify by code on OCP 4.5.0-0.nightly-2020-06-05-021159 on OSP13(2020-05-19.2).

Tests run as expected while code is confirmed to be present on the running kuryr-controller POD:

$ oc rsh -n openshift-kuryr kuryr-controller-696c89958-ndtbx  sed -n -e 494p -e 495p /usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/lbaasv2.py
            vip_subnet_id=loadbalancer.subnet_id,
            provider=loadbalancer.provider)

Comment 6 errata-xmlrpc 2020-07-13 17:43:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.