Bug 1844091 - Find_loadbalancer method should also use provider information
Summary: Find_loadbalancer method should also use provider information
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.z
Assignee: Luis Tomas Bolivar
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1843817
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-04 15:31 UTC by OpenShift BugZilla Robot
Modified: 2020-06-23 00:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-23 00:57:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 264 None closed [release-4.4] [release-4.5] Bug 1844091: Ensure provider information is used when finding lbs 2020-07-23 15:52:46 UTC
Red Hat Product Errata RHBA-2020:2580 None None None 2020-06-23 00:58:09 UTC

Description OpenShift BugZilla Robot 2020-06-04 15:31:07 UTC
+++ This bug was initially created as a clone of Bug #1843817 +++

+++ This bug was initially created as a clone of Bug #1842466 +++

Since OpenShift 4.4, kuryr support both amphora and ovn octavia loadbalancer drivers. Kuryr should differentiate existing loadbalancer depending on its provider too

Comment 3 rlobillo 2020-06-15 16:18:12 UTC
As the required conditions to match this scenario requires to perform amphora to ovn-octavia upgrade and this is still not supported, we agreed to verify by code on OCP 4.4.0-0.nightly-2020-06-14-142924 on OSP13(2020-06-09.2).

Tests run as expected while code is confirmed to be present on the running kuryr-controller POD:

$ oc rsh -n openshift-kuryr kuryr-controller-78494d6fdd-s58g6 sed -n -e 623p -e 624p /usr/lib/python3.6/site-packages/kuryr_kubernetes/controller/drivers/lbaasv2.py
            vip_subnet_id=loadbalancer.subnet_id,
            provider=loadbalancer.provider)

Comment 5 errata-xmlrpc 2020-06-23 00:57:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2580


Note You need to log in before you can comment on or make changes to this bug.