Bug 1843950 - control plane hosts no longer adopted in Ironic
Summary: control plane hosts no longer adopted in Ironic
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Doug Hellmann
QA Contact: Lubov
URL:
Whiteboard:
Depends On:
Blocks: 1844205
TreeView+ depends on / blocked
 
Reported: 2020-06-04 13:39 UTC by Stephen Benjamin
Modified: 2020-10-27 16:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1844205 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:05:23 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-operator pull 75 0 None closed Bug 1843950: remove infinite reconcile loop when fetching status annotation 2020-10-07 09:56:19 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:05:49 UTC

Description Stephen Benjamin 2020-06-04 13:39:26 UTC
Description of problem:

BareMetalHosts for the control plane no longer get adopted by Ironic, nor do they show "externally provisioned" as their status:

NAMESPACE               NAME              STATUS   PROVISIONING STATUS   CONSUMER                BMC                                    HARDWARE PROFILE   ONLINE   ERROR
openshift-machine-api   ostest-master-0                                  ostest-master-0         ipmi://[fd2e:6f44:5dd8:c956::1]:6230                      true     
openshift-machine-api   ostest-master-1                                  ostest-master-1         ipmi://[fd2e:6f44:5dd8:c956::1]:6231                      true     
openshift-machine-api   ostest-master-2                                  ostest-master-2         ipmi://[fd2e:6f44:5dd8:c956::1]:6232                      true  
$ openstack baremetal node list
+--------------------------------------+-----------------+--------------------------------------+-------------+--------------------+-------------+
| UUID                                 | Name            | Instance UUID                        | Power State | Provisioning State | Maintenance |
+--------------------------------------+-----------------+--------------------------------------+-------------+--------------------+-------------+
| cbd1083d-8cfc-4ee5-90ea-c401e4417cb3 | ostest-worker-0 | fe83b857-e323-4b6b-a097-e991d2dcaeac | power on    | active             | False       |
| e3917506-0e1e-4490-ac63-ebd1a7966a0a | ostest-worker-1 | 9d59ea8a-b42e-493f-9574-699abad4a22a | power on    | active             | False       |
+--------------------------------------+-----------------+--------------------------------------+-------------+--------------------+-------------+


Version-Release number of selected component (if applicable):

Latest 4.6 CI build

How reproducible:

Always

Steps to Reproduce:
1. Install OpenShift on baremetal IPI

Actual results:

Masters are online, but don't show externally provisioned anymore, and they don't get adopted into Ironic.

Expected results:

Masters show externally provisioned, and end up in the Ironic database.

Additional info:

Comment 1 Stephen Benjamin 2020-06-04 13:45:20 UTC
We also see this in 4.5, so it likely needs fixing and then backported.

Comment 2 Doug Hellmann 2020-06-04 18:06:20 UTC
https://github.com/metal3-io/baremetal-operator/pull/546 addresses this upstream in the baremetal-operator.

Comment 5 Lubov 2020-06-09 09:38:05 UTC
fix verified in 4.5

Comment 6 Lubov 2020-07-29 15:15:02 UTC
verified in 4.6

Comment 8 errata-xmlrpc 2020-10-27 16:05:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.