Bug 184424 - prism54 based wireless card fails to get firmware
prism54 based wireless card fails to get firmware
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-08 12:24 EST by Nathanael Noblet
Modified: 2008-01-19 23:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:40:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathanael Noblet 2006-03-08 12:24:00 EST
Description of problem:

When booting, the prism54 module is loaded, however it seems that the firmware
for the card is not. I think the module is loaded before udev is started so
perhaps no hotplug event gets triggered and the firmware is not loaded. Once the
machine fully boots I can get a connection after 'rmmod prism54' and 'modprobe
prism54'. This card worked flawlessly under dual boot windows and 3 versions
Ubuntu for the past 1.5 years. I'm fairly certain it is simply not getting the
firmware when the kernel is booting.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Reboot with a Prism54 based card in the system
2.
3.
  
Actual results:
eth0 times out

Expected results:
eth0 would acquire an IP

Additional info:
Comment 1 Demosthenes T. Mateo Jr. 2006-03-21 21:47:29 EST
Same thing happens for my ipw2200 firmware 2.4. The work around is to do
rmmod/modprobe in /etc/rc.local. The same WiFi card worked flawlessly in FC4.
FC4 has /usr/lib/hotplug but the FC5 release notes indicate that this has been
deprecated.
Comment 2 Dave Jones 2006-10-16 14:47:32 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 Jon Stanley 2008-01-19 23:40:28 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.