Bug 18450 - No PCMCIA CDROM installation possibility
No PCMCIA CDROM installation possibility
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
:
: 19735 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 13:22 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 14:53:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-05 13:22:17 EDT
Hye,
I want to install RH7 on a Laptop with external PCMCIA CDROM...
So I create PCMCIA Boot Disk and I boot
No problem with the boot, when I arrive on the installer, I choose
my language and my keyboard.
After this, only NFS, FTP, HTTP and local drive installation method
are offered to me as install method...  NO local CDROM  !!!!
So I hit Alt-F2, Alt-F3, Alt- F4 keys, And I see that my CDROM is found by 
cardmgr and put on HDC... (my PCMCIA ethernet card so !!!)
I back to the installer and I choose local drive and I just can choose
/dev/hda1 or /dev/hda2 but never /dev/hdc...
Can you help me ?

Thanks
Comment 1 Daniel Roesen 2000-10-05 13:33:00 EDT
Removing "0" as QA Contact as it generates a dead.letter :-]
Also removed the Summary shouting ;->

LART me if this was inappropriate :-}
Comment 2 Daniele Arduini 2000-10-23 06:43:15 EDT
PCMCIA CDROM installation doesn't work on my Acer TM313T too.
Please fix this ASAP!
Comment 3 Daniele Arduini 2000-10-23 08:24:04 EDT
I've got the time to save log messages printed during the install:

- Acer TravelMate 313 T (i586 MMX 266MHz, 96MB RAM, 3.1GB IDE HD)
- PCMCIA CD-ROM
- installing with floppy boot image (pcmcia.img)

console messages:

ALT-F2
...
* pcmcia probe returned: |PCI bridge probe: 02Micro 0Z6832/0Z6833 found, 2
sockets.
|
* need to load i82365
* going to insmod pcmcia_core.o (path is NULL)
* going to insmod i82365.o (path is NULL)
* going to insmod ds.o (path is NULL)
* cardmgr running as pid 20
* cardmgr returned 0x0
* probing buses
* finished bus probing
* found suggestion of i82365
* found suggestion of i82365
* found nothing

ALT-F3

...
<6>  02Micro 0Z6832/33 rev 34 PCI-to-CardBus at slot 00:06, mem 0x68000000
<6>    host opts [0]: [pci/way] [pci irq 9] [lat 168/176] [bus 32/34]
<6>    host opts [1]: [pci/way] [pci irq 9] [lat 168/176] [bus 35/37]
<6>    ISA irqs (default) = 3,4,5,7,10,11,12,15 PCI status changes
<30>Oct 23 15:13:17 cardmgr[20]: starting, version is 3.1.8
<30>Oct 23 15:13:17 cardmgr[20]: watching 2 sokets
<30>Oct 23 15:13:17 cardmgr[20]: Card Services release does not match!
<6>cs: IO port probe 0x0c00-0x0cff: excluding 0xcf8-0xcff
<6>cs: IO port probe 0x0800-0x08ff: clean.
<6>cs: IO port probe 0x0100-0x04ff: exluding 0x378-0x37f 0x4d0-0x4d7
<6>cs: IO port probe 0x0a00-0x0aff: clean.
<30>Oct 23 15:13:17 cardmgr[20]: could not open /var/run/cardmgr.pid: %m
<30>Oct 23 15:13:17 cardmgr[20]: fopen(stabfile) failed: %m
<30>Oct 23 15:13:18 cardmgr[20]: initializing socket 0
<6>cs: memory probe 0xa0000000-0xa0ffffff: exluding 0xa0000000-0xa00fffff
<30>Oct 23 15:13:18 cardmgr[20]: socket 0: ATA/IDE Fixed Disk
<30>Oct 23 15:13:18 cardmgr[20]: executing: 'modprobe ide_cs.o'
<4>hdc: CD-ROM CDR_U240, ATAPI CDROM drive
<4>ide1 at 0x100-0x107,0x10e on irq 3
<4>hdc: ATAPI 23X CD-ROM drive, 256kB Cache
<6>Uniform CD-ROM driver Revision: 3.10
<6>ide_cs: hdc: Vcc = 5.0, Vpp = 0.0
<30>Oct 23 15:13:27 cardmgr[20]: fopen(stabfile) failed: %m
<30>Oct 23 15:13:28 cardmgr[20]: exiting


------------------------------------------------
But the same CD-ROM inserted on a already running RHL 6.2:

Oct 23 16:04:55 localhost kernel: Linux PCMCIA Card Services 3.1.8
Oct 23 16:04:55 localhost kernel:   kernel build: 2.2.14-12 #1 Tue Apr 25
12:50:06 EDT 2000
Oct 23 16:04:55 localhost kernel:   options:  [pci] [cardbus] [apm]
Oct 23 16:04:55 localhost kernel: Intel PCIC probe:
Oct 23 16:04:55 localhost kernel:   O2Micro OZ6832/OZ6833 PCI-to-CardBus at bus
0 slot 6, mem 0x68000000, 2 sockets
Oct 23 16:04:55 localhost kernel:     host opts [0]: [a 44] [b 0d] [c 20] [d 06]
[mhpg 18] [fifo 00] [e 0a] [no pci irq] [lat 168/176] [bus 32/34]
Oct 23 16:04:55 localhost kernel:     host opts [1]: [a 44] [b 01] [c 20] [d 06]
[mhpg 18] [fifo 00] [e 0a] [no pci irq] [lat 168/176] [bus 35/37]
Oct 23 16:04:55 localhost kernel:     ISA irqs (default) = 3,4,7,11,15 polling
interval = 1000 ms
Oct 23 16:04:55 localhost cardmgr[712]: starting, version is 3.1.8
Oct 23 16:04:55 localhost cardmgr[712]: watching 2 sockets
Oct 23 16:04:55 localhost kernel: cs: IO port probe 0x1000-0x17ff: clean.
Oct 23 16:04:55 localhost kernel: cs: IO port probe 0x0100-0x04ff: excluding
0x110-0x117 0x220-0x22f 0x378-0x37f 0x3e8-0x3ff 0x4d0-0x4d7
Oct 23 16:04:55 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Oct 23 16:05:18 localhost cardmgr[712]: initializing socket 0
Oct 23 16:05:18 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff:
excluding 0xa0000000-0xa00fffff
Oct 23 16:05:18 localhost cardmgr[712]: socket 0: ATA/IDE Fixed Disk
Oct 23 16:05:18 localhost cardmgr[712]: executing: 'insmod
/lib/modules/2.2.14-12/pcmcia/ide_cs.o'
hdc: CD-ROM CDR_U240, ATAPI CDROM drive
ide1 at 0x100-0x107,0x10e on irq 3
Oct 23 16:05:22 localhost kernel: hdc: CD-ROM CDR_U240, ATAPI CDROM drive
Oct 23 16:05:22 localhost kernel: ide1 at 0x100-0x107,0x10e on irq 3
hdc: ATAPI 23X CD-ROM drive, 256kB Cache
Oct 23 16:05:22 localhost kernel: hdc: ATAPI 23X CD-ROM drive, 256kB Cache
Oct 23 16:05:22 localhost kernel: Uniform CDROM driver Revision: 2.56
Oct 23 16:05:22 localhost kernel: ide_cs: hdc: Vcc = 5.0, Vpp = 0.0
Oct 23 16:05:22 localhost cardmgr[712]: executing: './ide start hdc'
Oct 23 16:05:22 localhost cardmgr[712]: + ./ide: /sbin/ide_info: File o
directory inesistente
Comment 4 Need Real Name 2000-10-25 11:29:34 EDT
I have exactly this problem (with strikingly similar console messages) on a 
Hitachi Visionbook Traveler Series 3000.
Comment 5 Michael Fulbright 2000-10-30 16:22:20 EST
*** Bug 19735 has been marked as a duplicate of this bug. ***
Comment 6 Erik Troan 2000-11-20 15:49:29 EST
This is because the 2.2 kernel doesn't populate /proc wide information on PCMCIA
IDE devices. The 2.4 kernel has this fixed, so the next release of RH will work
fine on these devices (they've been tested in house).
Comment 7 Aaron Brown 2000-12-13 13:46:20 EST
Verified as resolved.

Note You need to log in before you can comment on or make changes to this bug.