Bug 19735 - Can't Install from IBM Thinkpad Portable Drive Bay CD-ROM
Can't Install from IBM Thinkpad Portable Drive Bay CD-ROM
Status: CLOSED DUPLICATE of bug 18450
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-25 00:26 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 16:22:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-25 00:26:33 EDT
I'm trying to install Deluxe Workstation 7.0 from the boxed set on an IBM 
Thinkpad 240X with the IBM Portable Drive Bay and the IBM 24X CD-ROM 
installed. The drive bay connects to the laptop using a PCMCIA card that 
appears to be an IDE interface. The BIOS does not seem to have an option for 
booting from the CD-ROM. I created a boot disk from the "pcmcia.img" file on 
the installation CD-ROM. When I bootstrap the machine, I eventually see a 
quick dialog box "Initializing PC Card Devices." This is followed by two 
high-pitched beeps.

I then go through the language and keyboard selections, but when I get to 
the Installation Method menu, my only choice is "Hard Drive." I'll try to 
copy the <CTRL><ALT><F4> log messages below:

<6>    ISA irqs (scanned) = 3,4,7,9,10,15 PCI status changes
<30>Oct 24 21:58:44 cardmgr[20]: starting, version is 3.1.8
<30>Oct 24 21:58:44 cardmgr[20]: watching 1 sockets
<30>Oct 24 21:58:44 cardmgr[20]: Card Services release does not match!
<6>cs: IO port probe 0x0c00-0x0cff: excluding 0xcf8-0xcff
<6>cs: IO port probe 0x0800-0x08ff: clean.
<6>cs: IO port probe 0x0100-0x04ff: excluding 0x398-0x39f 0x3b8-0x3df 0x4d0-
0x4d7
<30>Oct 24 21:58:44 cardmgr[20]: could not open /var/run/cardmgr.pid: %m
<30>Oct 24 21:58:44 cardmgr[20]: fopen(stabfile) failed: %m
<30>Oct 24 21:58:45 cardmgr[20]: initializing socket 0
<6>cs: memory probe 0xa0000000-0xa0ffffff: clean.
<30>Oct 24 21:58:45 cardmgr[20]: socket 0: IBM Portable Drive Bay
<30>Oct 24 21:58:45 cardmgr[20]: executing: '/modprobe ide_cs.0'
<4>hdc: TOSHIBA CD-ROM XM-7002B, ATAPI CDROM drive
<4>ide1 at 0x320-0x327,0x32e on irq 3
<4>hdc: ATAPI 24X CD-ROM drive, 128kB Cache
<6>Uniform CD-ROM driver Revision: 3.10
<6>ide_cs: hdc: Vcc = 5.0, Vpp=0.0
<30>Oct 24 21:58:49 cardmgr[20]: fopen(stabfile) failed: %m
<30>Oct 24 21:58:49 cardmgr[20]: exiting

Clearly the OS recognizes the hardware at some low level, but the CD-ROM 
support is being lost somewhere between there and the installer software.

I gave this a high priority for two reasons. First, I have no other way to 
install the software. Second, I only bought the software because presales 
support told me that the hardware was supported.

Any help you can provide will be greatly appreciated!
Comment 1 Need Real Name 2000-10-27 08:23:42 EDT
I suppose I should mention that the CD-ROM drive in the Portable Drive Bay works 

fine with Windows, so the device itself appears to be fine.

Comment 2 Need Real Name 2000-10-29 21:33:01 EST
After some feedback from support (See service request 160875), I'm coming to the 

conclusion that either (a) RH 7.0 does not support the IBM CD-ROM as promised, or 

(b) there may be a programming error in the pcmcia.img installation program.



Support suggested that the driver for the CD-ROM was on the drivers.img disk 

image on the installation CD-ROM, and that I try doing the installation from 

expert mode. I did this, installing the drivers disk when prompted, but despite 

the fact that there clearly ARE CD-ROM drivers among those on the drivers.img 

disk, when I get to the "Installation Method" menu, the only device class 

displayed is "Hard Drive," and the only drivers available from drivers.img 

(accessed with <F2>) are hard disk drivers.



Thus, it seems that either there is no appropriate driver for the CD-ROM (and 

indeed, none of the drivers in the drivers.img bundle appear to be for an IBM or 

Toshiba drive), or if some generic driver does support the IBM/Toshiba hardware, 

the installation program is not showing it to me.

Comment 3 Michael Fulbright 2000-10-30 16:22:23 EST
If the drive is a EIDE based drive then you shouldn't require a driver disk.

This problem has been reported previously - thank you for the information you
have provided.

*** This bug has been marked as a duplicate of 18450 ***

Note You need to log in before you can comment on or make changes to this bug.