Bug 1845202 - ovnkube-master sometimes stops handling pod updates.
Summary: ovnkube-master sometimes stops handling pod updates.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.5
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.5.0
Assignee: Casey Callendrello
QA Contact: Anurag saxena
URL:
Whiteboard:
: 1843396 (view as bug list)
Depends On: 1841828
Blocks: 1843946 1845724
TreeView+ depends on / blocked
 
Reported: 2020-06-08 16:02 UTC by Casey Callendrello
Modified: 2020-07-13 17:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1845724 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:43:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 178 None closed Bug 1845202: Fix deadlock, fix service lag. 2020-07-07 21:00:48 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:44:06 UTC

Description Casey Callendrello 2020-06-08 16:02:22 UTC
This bug was initially created as a copy of Bug #1841828

I am copying this bug because: 



Description of problem:
Sometimes the ovnkube-master stops processing pod updates

https://storage.googleapis.com/origin-ci-test/pr-logs/pull/openshift_ovn-kubernetes/174/pull-ci-openshift-ovn-kubernetes-master-e2e-gcp-ovn/1176/artifacts/e2e-gcp-ovn/pods/openshift-ovn-kubernetes_ovnkube-master-82blj_ovnkube-master.log at 15:14

Version-Release number of selected component (if applicable):
4.5

How reproducible:

Seems to happen in about 1-in-20 CI runs.

Comment 6 Antonio Ojea 2020-06-17 11:32:34 UTC
*** Bug 1843396 has been marked as a duplicate of this bug. ***

Comment 7 W. Trevor King 2020-06-25 06:20:23 UTC
Based on [1], this series should address CI flakes for:

[sig-network] NetworkPolicy [LinuxOnly] NetworkPolicy between server and client should enforce policy based on PodSelector with MatchExpressions[Feature:NetworkPolicy]

Copying the test name in here so it turns up in Sippy results as a non-dup bug.

[1]: https://bugzilla.redhat.com/show_bug.cgi?id=1845740#c2

Comment 8 errata-xmlrpc 2020-07-13 17:43:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.