Bug 18457 - Installer fails if insufficient disk space
Installer fails if insufficient disk space
Status: CLOSED DUPLICATE of bug 18305
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: 0
0
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-05 14:56 EDT by roxus
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 14:28:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description roxus 2000-10-05 14:56:39 EDT
After partitioning a disk (all the way up to /dev/hda14) and selecting
every package required (un-selecting all packages that I didn't want too)
the installer informed me that I did not have enuff disk space on some
partitions to install the software. So I went back to Disk Druid and
modified the paritition sizes. The installer then failed with a warning
that the partition table had been altered and the kernel needed to be
rebooted. The reboot is ONLY necessary if the partition of the / filesystem
is altered (which is a RAM disk from the installation, so it definitely
isn't required). After the reboot, Disk Druid does NOT show the last
changes that were made (they weren't saved to the partition table it seems)
so I had to try to remember how much space to make the altereations for
once again. Then try to remember what packages I had [un]selected again,
only to be told, once again, that I have insufficient disk space on only
one partition this time. Still, not wanting to go thru ALL THAT again, I
selected Next to ignore the warning/error and anaconda crashed. I don't
have the error messages, but it had to do with partition sizes and required
diskspace, so there is something in the code there not acounting for this
situation.

I think I'm just going to install on one big, huge partition (ugh!) and add
a second HD and then partition as fits, and then cp the installation over,
and then redo the partition information on the original HD and THEN copy
the installation BACK to the originial HD. Why ? Becoz I reported EXACTLY
the same sort of error for RH6.0 and RH6.2. There is definitely
insufficient testing of the installer for the scenario when ppl DON'T just
install everything on one big huge partition, and DON'T provide enuff space
on the created partitions. Why can't you do the package selecting phase
BEFORE the partitioning phase so that the requirements for size are known
BEFORE the partitioning is selected ?
Comment 1 Michael Fulbright 2000-10-09 14:28:16 EDT

*** This bug has been marked as a duplicate of 18305 ***

Note You need to log in before you can comment on or make changes to this bug.