Bug 18305 - Increasing partition sizes during install doesn't stop need more space message
Increasing partition sizes during install doesn't stop need more space message
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
: 18457 20722 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-04 04:04 EDT by Rick Richardson
Modified: 2007-03-26 23:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-02 15:14:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Richardson 2000-10-04 04:04:33 EDT
Partitioned disk with 2GB for /, 7GB for /home.
Then selected to install everything.  When it got to the
package install step, claimed I need 196MB's more space.

So I used the "back" button (many times) to return to the
partition step.  I repartitioned to 3GB for /, 6GB for /home.
Then proceeded to install as before.  It still claimed I
needed 196MB's more space.

So I repeated the above and repartitioned to 4GB for /.
Got same problem.  At this point, I figured the install
program was hopelessly confused, so I decided to
start over from a fresh boot of the install disk.

So, basically if you screw up and undersize the partitions
in the installer, there is no way to fix this short of starting
over at the very beginning.

Also, it would be *very* nice if I had an *onscreen* idea what the
space requirements on / (and /usr) are *before* I hit the partitioning
step.
Comment 1 Michael Fulbright 2000-10-05 18:03:30 EDT
Was this an upgrade or install?
Comment 2 Rick Richardson 2000-10-05 18:35:12 EDT
The was a from scratch install, not upgrade.
Comment 3 Michael Fulbright 2000-10-06 16:40:46 EDT
Please try to reproduce Brent.
Comment 4 Brent Fox 2000-10-06 23:30:18 EDT
Actually, I tried to reproduce this and ran across a different but related
problem.  I assigned 2 Gigs for / and 3 Gigs for /home.  Doing an everything
install, anaconda said that the install would be around 1.9 gigs.  Since I gave
2 Gigs to /, that should be enough space, although just barely.  However, just
prior to installing the packages, anaconda says that I don't have enough disk
space and that I need over 200 MB more.  Then, when I back up and give / more
space in Disk Druid (3 Gigs this time), I get an error message at the package
selection screen this time saying:
"The kernel is unable to read your new partitioning information, probably
because you modified extended partitions.  While this is not critical, you must
reboot your machine before proceeding.  Insert the Red Hat boot disk now and
press "OK" to reboot your system".  Seems like there should be a more elegant
way to let the user resize partition size.  
So, I was unable to reproduce the original problem about the installer not
recalculating for the additional partition space.
Comment 5 Rick Richardson 2000-10-06 23:56:55 EDT
I think you are on the right track.  In my case, I didn't use any extended
partitions.
partition 1 was 32MB for /boot.  Partition 2 was 128MB for <swap>, Patition 3
was (initial attempt) 2MB, and Partition 4 was everything else (I used fdisk to
do the partioning).

I suspect you went down a slightly different error path because of the extended
partitions and thus got the message that said "give it up now and start over",
rather than being teased to try again like I was.

Anyway, I'm glad you repro'ed something.  I think you guys could probably fix
this bug pretty easily, but I think a better fix would be to reorganize the
install
so that you do the package selection before the partitioning.  Then you could
provide useful information like "hey dude, if you want just /, you'll need XXX
MB's.  if you want / and /usr you'll need XXX and YYY MB's, etc."
Comment 6 Brent Fox 2000-10-07 00:37:26 EDT
Out of curiousity, I tried something different.  I used fdisk and made
partitions identical to yours and got the out of space message.  Then, I backed
up to the screen where you set the mount points and switched the partitions so
that partition 3 (the 2 Gig) was /home and partition 4 (everything else) was /. 
The install went fine from there.  So, at least in this situation there is some
way to fix the size problem without rebooting.  I'll try to reproduce your
situation exactly tomorrow.
Comment 7 Brent Fox 2000-10-08 11:28:45 EDT
Ok, I reproduced your situation exactly and have verified the bug.  We will
address this in the next release.  I'm changing the priority of this bug to
high.
Comment 8 Michael Fulbright 2000-10-09 14:28:12 EDT
*** Bug 18457 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2000-11-15 11:18:10 EST
*** Bug 20722 has been marked as a duplicate of this bug. ***
Comment 10 Brent Fox 2000-12-29 18:23:44 EST
The reason we do disk partitioning first is because on machines with very small
amounts of ram, we have to enabe swap space as soon as possible.  The only way
to do this is to have the user create a swap partition.
Comment 11 Rick Richardson 2000-12-29 22:45:29 EST
Well, you could easily detect that you are on a machine with limited RAM, and in
that case partition just a (perhaps temporary) swap partition.   For machines
with
sufficient RAM, skip this step.

Then you do the package selection, telling the user how big /, /usr, /var, etc
need to
be at a minimum.  Then the user creates the partitions they want based on the
minimum
recommendations.  Then you mount the new permanent swap area.  Then you install
the packages.

I think this would be far easier for the average person to deal with, rather
than the "guess"
method for partition sizes that the current method requires.
Comment 12 Brent Fox 2001-02-03 00:27:32 EST
I agree that this would be nice to have, but it requires more changes to the
code than we can make at this time.  Deferring to a future release.

Note You need to log in before you can comment on or make changes to this bug.