Bug 1845815 - Console crash when creating EtcdRestore instance
Summary: Console crash when creating EtcdRestore instance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1847277
TreeView+ depends on / blocked
 
Reported: 2020-06-10 06:47 UTC by Yadan Pei
Modified: 2020-10-27 16:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On the create EtcdRestore form, the k8sResourceSelector for one of the fields was not being passed a k8s model. Consequence: A runtime error occurred when trying to access a property of a non-existent model. Fix: Add a check to ensure that the model is defined before accessing its properties, and only render the resulting k8s resource dropdown if the model exists. Result: No runtime error is encountered on the EtcdRestore creation page, and the k8s resource dropdown that was causing the problem is omitted from the form.
Clone Of:
: 1847277 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:06:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5716 0 None closed Bug 1845815: Fix legacy operand form runtime error 2020-07-22 00:07:48 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:06:38 UTC

Description Yadan Pei 2020-06-10 06:47:35 UTC
Description of problem:


Version-Release number of selected component (if applicable):
4.5.0-0.nightly-2020-06-09-201617

How reproducible:
Always

Steps to Reproduce:
1. subscribe etcd Operator to one project and wait until etcd Operator is successfully subscribed
2. create EtcdRestore instance via Operators -> Installed Operators -> etcd -> click on EtcdRestore -> click 'Create EtcdRestore' button
3.

Actual results:
2. console crashed and blank page returnred
TypeError: "o is undefined"
    Se create-operand-chunk-8f7c184d9f0ade7a8b16.min.js:1
    ke create-operand-chunk-8f7c184d9f0ade7a8b16.min.js:1
    a vendors~main-chunk-24ac84a45fe5cba32c70.min.js:18508
    a vendors~main-chunk-24ac84a45fe5cba32c70.min.js:104
    ke create-operand-chunk-8f7c184d9f0ade7a8b16.min.js:1
    ke create-operand-chunk-8f7c184d9f0ade7a8b16.min.js:1
    Fo vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    Ks vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    Bs vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    Ns vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    Ds vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    di vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    unstable_runWithPriority vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161683
    li vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    di vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    pi vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    Is vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
    notify vendors~main-chunk-24ac84a45fe5cba32c70.min.js:34831
    notifyNestedSubs vendors~main-chunk-24ac84a45fe5cba32c70.min.js:34831
    notifySubscribers vendors~main-chunk-24ac84a45fe5cba32c70.min.js:102001
    handleChangeWrapper vendors~main-chunk-24ac84a45fe5cba32c70.min.js:34831
    v vendors~main-chunk-24ac84a45fe5cba32c70.min.js:18508
    b main-chunk-de4ff261cc3bde5ad14a.min.js:1
    dispatch vendors~main-chunk-24ac84a45fe5cba32c70.min.js:18508
    l main-chunk-de4ff261cc3bde5ad14a.min.js:1
vendors~main-chunk-24ac84a45fe5cba32c70.min.js:161389
Uncaught error 
unhandledrejection { target: Window, isTrusted: true, promise: Promise { "rejected" }, reason: TypeError, srcElement: Window, currentTarget: Window, eventPhase: 2, bubbles: false, cancelable: true, returnValue: true, … }

Expected results:
2. operand creation form is loaded succcessfully

Additional info:

Comment 4 XiaochuanWang 2020-06-15 06:59:53 UTC
'Create EtcdRestore' button works now.
Checked the button from 3 places: 
1) Installed Operaotor -> etcd detail page -> Create Instance
2) Installed Operaotor -> etcd -> All Instance page -> Create New -> etcd Restore
3) Installed Operaotor -> etcd -> etcd Restore page -> Create EtcdRestore

Verified on 4.6.0-0.nightly-2020-06-12-084204

Comment 6 errata-xmlrpc 2020-10-27 16:06:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.