Bug 1847277 - Console crash when creating EtcdRestore instance
Summary: Console crash when creating EtcdRestore instance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.z
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1845815
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-16 05:52 UTC by Yadan Pei
Modified: 2020-07-30 18:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On the create EtcdRestore form, the k8sResourceSelector for one of the fields was not being passed a k8s model. Consequence: A runtime error occurred when trying to access a property of a non-existent model. Fix: Add a check to ensure that the model is defined before accessing its properties, and only render the resulting k8s resource dropdown if the model exists. Result: No runtime error is encountered on the EtcdRestore creation page, and the k8s resource dropdown that was causing the problem is omitted from the form.
Clone Of: 1845815
Environment:
Last Closed: 2020-07-30 18:56:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5751 None closed [release-4.5] Bug 1847277: Fix legacy operand form runtime error 2020-07-29 12:27:58 UTC
Red Hat Product Errata RHBA-2020:3028 None None None 2020-07-30 18:57:18 UTC

Comment 1 Jon Jackson 2020-06-19 13:29:37 UTC
PR pending.

Comment 2 Jon Jackson 2020-07-02 19:29:48 UTC
https://github.com/openshift/console/pull/5751

Comment 5 XiaochuanWang 2020-07-24 06:03:46 UTC
This does not reproduced. Verified on 4.5.0-0.nightly-2020-07-23-201307

Comment 7 errata-xmlrpc 2020-07-30 18:56:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3028


Note You need to log in before you can comment on or make changes to this bug.