Bug 1845817 - It always shows a loading icon for AWS Secret field
Summary: It always shows a loading icon for AWS Secret field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.6.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1820431 (view as bug list)
Depends On:
Blocks: 1848383 1848530
TreeView+ depends on / blocked
 
Reported: 2020-06-10 06:56 UTC by Yadan Pei
Modified: 2020-10-27 16:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ListDropdown component was ignored loading state if the selectedKey prop did not exist in the items object. Consequence: A loading icon was displayed until the user selected an item from the dropdown. Fix: Update Dropdown component logic so that the loading icon is only displays if the dropdown is actually in a loading state. Result: If selectedKey doesn't exist in the items object, and the ListDropdown is not in a loading state, a placeholder is displayed.
Clone Of:
Environment:
Last Closed: 2020-10-27 16:06:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5755 0 None closed Bug 1845817: Fix ListDropdown loading state 2020-10-15 20:03:45 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:06:38 UTC

Description Yadan Pei 2020-06-10 06:56:41 UTC
Description of problem:
on EtcdBackup creation form, 'AWS Secret' descriptor always shows a loading ... icon until user select one secret from dropdown

Version-Release number of selected component (if applicable):
    4.5.0-0.nightly-2020-06-09-201617

How reproducible:
Always

Steps to Reproduce:
1. subscribe etcd operator and wait until successfully subscribed
2. create EtcdBackup instance via Operators -> Installed Operators -> etcd -> click on 'etcd Backup' -> click 'Create EtcdBackup' button


Actual results:
2. the 'AWS Secret' dropdown always shows loading ... until user select one secret from dropdown
          - description: >-
              The name of the secret object that stores the AWS credential and
              config files.
            displayName: AWS Secret
            path: s3.awsSecret
            x-descriptors:
              - 'urn:alm:descriptor:io.kubernetes:Secret'


Expected results:
2. If secrets are loaded completely, we should not show a loading icon ... any more

Additional info:

Comment 1 Jakub Hadvig 2020-06-11 07:46:01 UTC
The problem is that use the `<aws-secret>` placeholder as a selectedKey for the ListDropdown component, which doesn't exist.
For the fix we should update the ListDropdown so when the key does not exist no item will be selected, to avoid loading icon.

Comment 2 Samuel Padgett 2020-06-18 14:19:03 UTC
*** Bug 1820431 has been marked as a duplicate of this bug. ***

Comment 5 XiaochuanWang 2020-06-22 06:35:05 UTC
Still reproduces on current payload, will check on the version later than: 4.6.0-0.nightly-2020-06-20-011219

Comment 6 shahan 2020-06-23 08:48:47 UTC
The AWS secret would display “select secret” other than loading
4.6.0-0.nightly-2020-06-23-033310

Comment 8 errata-xmlrpc 2020-10-27 16:06:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.