Bug 1848530 - It always shows a loading icon for AWS Secret field
Summary: It always shows a loading icon for AWS Secret field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.5.z
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1848383 (view as bug list)
Depends On: 1845817
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-18 13:44 UTC by OpenShift BugZilla Robot
Modified: 2020-08-17 20:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: ListDropdown component was ignored loading state if the selectedKey prop did not exist in the items object. Consequence: A loading icon was displayed until the user selected an item from the dropdown. Fix: Update Dropdown component logic so that the loading icon is only displays if the dropdown is actually in a loading state. Result: If selectedKey doesn't exist in the items object, and the ListDropdown is not in a loading state, a placeholder is displayed.
Clone Of:
Environment:
Last Closed: 2020-08-17 20:05:19 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5778 None closed [release-4.5] Bug 1848530: Fix ListDropdown loading state 2020-08-10 06:50:20 UTC
Red Hat Product Errata RHBA-2020:3330 None None None 2020-08-17 20:05:40 UTC

Description OpenShift BugZilla Robot 2020-06-18 13:44:33 UTC
+++ This bug was initially created as a clone of Bug #1845817 +++

Description of problem:
on EtcdBackup creation form, 'AWS Secret' descriptor always shows a loading ... icon until user select one secret from dropdown

Version-Release number of selected component (if applicable):
    4.5.0-0.nightly-2020-06-09-201617

How reproducible:
Always

Steps to Reproduce:
1. subscribe etcd operator and wait until successfully subscribed
2. create EtcdBackup instance via Operators -> Installed Operators -> etcd -> click on 'etcd Backup' -> click 'Create EtcdBackup' button


Actual results:
2. the 'AWS Secret' dropdown always shows loading ... until user select one secret from dropdown
          - description: >-
              The name of the secret object that stores the AWS credential and
              config files.
            displayName: AWS Secret
            path: s3.awsSecret
            x-descriptors:
              - 'urn:alm:descriptor:io.kubernetes:Secret'


Expected results:
2. If secrets are loaded completely, we should not show a loading icon ... any more

Additional info:

--- Additional comment from jhadvig@redhat.com on 2020-06-11 07:46:01 UTC ---

The problem is that use the `<aws-secret>` placeholder as a selectedKey for the ListDropdown component, which doesn't exist.
For the fix we should update the ListDropdown so when the key does not exist no item will be selected, to avoid loading icon.

Comment 1 Samuel Padgett 2020-06-18 13:55:33 UTC
*** Bug 1848383 has been marked as a duplicate of this bug. ***

Comment 2 Jon Jackson 2020-06-19 13:31:03 UTC
PR pending

Comment 3 Jon Jackson 2020-07-31 19:56:14 UTC
PR is open, awaiting cherry pick approval.

Comment 6 Yanping Zhang 2020-08-10 09:47:11 UTC
Tested on OCP 4.5 cluster with payload 4.5.0-0.nightly-2020-08-08-162221.
1. subscribe etcd operator and wait until successfully subscribed
2. create EtcdBackup instance via Operators -> Installed Operators -> etcd -> click on 'etcd Backup' -> click 'Create EtcdBackup' button.
The 'AWS Secret' dropdown works well now.
The bug is fixed.

Comment 8 errata-xmlrpc 2020-08-17 20:05:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.6 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3330


Note You need to log in before you can comment on or make changes to this bug.