Bug 1845829 - [upgrade]Pipeline build keeps new status after upgrade jenkins server from 4.4 to 4.5
Summary: [upgrade]Pipeline build keeps new status after upgrade jenkins server from 4....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.0
Assignee: Akram Ben Aissi
QA Contact: Jitendar Singh
URL:
Whiteboard:
Depends On:
Blocks: 1845902
TreeView+ depends on / blocked
 
Reported: 2020-06-10 07:51 UTC by XiuJuan Wang
Modified: 2020-10-27 16:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1845902 1847442 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:06:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
jenkins pod log (46.55 KB, text/plain)
2020-06-10 07:52 UTC, XiuJuan Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift jenkins pull 1079 0 None closed Bug 1845829: Set image version for the upgrade process 2020-06-22 12:52:39 UTC
Github openshift jenkins pull 1080 0 None closed Bug 1845902: Set OPENSHIFT_JENKINS_IMAGE_VERSION=4.5 2020-06-22 12:52:40 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:06:38 UTC

Description XiuJuan Wang 2020-06-10 07:51:05 UTC
Description of problem:
Pipeline build keeps new status after upgrade jenkins server from 4.4 to 4.5
And failed to sync pipeline build from cli client and jenkins webconsole.

https://github.com/openshift/jenkins/blob/release-4.4/2/contrib/openshift/base-plugins.txt
https://github.com/openshift/jenkins/blob/release-4.5/2/contrib/openshift/base-plugins.txt

Version-Release number of selected component (if applicable):

4.4.0-0.nightly-2020-06-08-083627 -> 4.5.0-rc.1
How reproducible:
always

Steps to Reproduce:
1.Prepare jenkins server and pipeline build(https://github.com/openshift/origin/tree/master/examples/jenkins/pipeline) in 4.4 cluster

2.Upgrade 4.4 cluster to 4.5
3.Trigger pipeline build again.

Actual results:
The pipeline build is triggered from cli client keeps in new status.
The pipelibe build is triggered from jenkins webconsole keeps in running, and don't sync to cli side.

 oc get builds
 NAME                            TYPE              FROM          STATUS     STARTED       DURATION
sample-pipeline-1               JenkinsPipeline                 Complete   4 hours ago   
nodejs-mongodb-example-1        Source            Git@a096bd2   Complete   4 hours ago   1m16s
openshift-jee-sample-1          JenkinsPipeline                 Complete   4 hours ago   
openshift-jee-sample-docker-1   Docker            Binary        Complete   4 hours ago   1m5s
openshift-jee-sample-2          JenkinsPipeline                 Complete   2 hours ago   
sample-pipeline-2               JenkinsPipeline                 Complete   2 hours ago   
nodejs-mongodb-example-2        Source            Git@a096bd2   Complete   2 hours ago   1m17s
openshift-jee-sample-docker-2   Docker            Binary        Complete   2 hours ago   1m7s
sample-pipeline-3               JenkinsPipeline                 New                      
openshift-jee-sample-3          JenkinsPipeline                 New    


Expected results:

New pipeline builds could go to completed.
Additional info:

Comment 1 XiuJuan Wang 2020-06-10 07:52:49 UTC
Created attachment 1696453 [details]
jenkins pod log

Comment 2 Akram Ben Aissi 2020-06-10 11:51:06 UTC
will be cherrry picked for 4.5

Comment 3 Akram Ben Aissi 2020-06-10 12:17:05 UTC
The OPENSHIFT_JENKINS_IMAGE_VERSION in the Jenkins 4.5 image was incorrectly set to 4.0, hence, the old plugins coming to 4.4 were not fully overridden, letting the openshift-sync plugin missing the kubernetes-client and not working anymore.

The fix consist in aligning OPENSHIFT_JENKINS_IMAGE_VERSION .
A PR is baking for 4.6 and will be manually cherry-picked to 4.5

Comment 4 Jitendar Singh 2020-06-11 12:44:36 UTC
Verified.

Comment 7 errata-xmlrpc 2020-10-27 16:06:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.