Bug 1845902 - [upgrade]Pipeline build keeps new status after upgrade jenkins server from 4.4 to 4.5
Summary: [upgrade]Pipeline build keeps new status after upgrade jenkins server from 4....
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Akram Ben Aissi
QA Contact: Jitendar Singh
URL:
Whiteboard:
Depends On: 1845829
Blocks: 1847442
TreeView+ depends on / blocked
 
Reported: 2020-06-10 11:55 UTC by Akram Ben Aissi
Modified: 2020-07-13 17:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1845829
: 1847452 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:43:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift jenkins pull 1081 0 None closed Bug 1845902: Set OPENSHIFT_JENKINS_IMAGE_VERSION 2020-07-30 00:51:57 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:44:07 UTC

Description Akram Ben Aissi 2020-06-10 11:55:48 UTC
+++ This bug was initially created as a clone of Bug #1845829 +++

Description of problem:
Pipeline build keeps new status after upgrade jenkins server from 4.4 to 4.5
And failed to sync pipeline build from cli client and jenkins webconsole.

https://github.com/openshift/jenkins/blob/release-4.4/2/contrib/openshift/base-plugins.txt
https://github.com/openshift/jenkins/blob/release-4.5/2/contrib/openshift/base-plugins.txt

Version-Release number of selected component (if applicable):

4.4.0-0.nightly-2020-06-08-083627 -> 4.5.0-rc.1
How reproducible:
always

Steps to Reproduce:
1.Prepare jenkins server and pipeline build(https://github.com/openshift/origin/tree/master/examples/jenkins/pipeline) in 4.4 cluster

2.Upgrade 4.4 cluster to 4.5
3.Trigger pipeline build again.

Actual results:
The pipeline build is triggered from cli client keeps in new status.
The pipelibe build is triggered from jenkins webconsole keeps in running, and don't sync to cli side.

 oc get builds
 NAME                            TYPE              FROM          STATUS     STARTED       DURATION
sample-pipeline-1               JenkinsPipeline                 Complete   4 hours ago   
nodejs-mongodb-example-1        Source            Git@a096bd2   Complete   4 hours ago   1m16s
openshift-jee-sample-1          JenkinsPipeline                 Complete   4 hours ago   
openshift-jee-sample-docker-1   Docker            Binary        Complete   4 hours ago   1m5s
openshift-jee-sample-2          JenkinsPipeline                 Complete   2 hours ago   
sample-pipeline-2               JenkinsPipeline                 Complete   2 hours ago   
nodejs-mongodb-example-2        Source            Git@a096bd2   Complete   2 hours ago   1m17s
openshift-jee-sample-docker-2   Docker            Binary        Complete   2 hours ago   1m7s
sample-pipeline-3               JenkinsPipeline                 New                      
openshift-jee-sample-3          JenkinsPipeline                 New    


Expected results:

New pipeline builds could go to completed.
Additional info:

--- Additional comment from XiuJuan Wang on 2020-06-10 07:52:49 UTC ---



--- Additional comment from Akram Ben Aissi on 2020-06-10 11:51:06 UTC ---

will be cherrry picked for 4.5

Comment 1 Akram Ben Aissi 2020-06-11 10:25:17 UTC
The reproducer for this one consists in a 4.5 cluster to start a Jenkins instance using the 4.4 image and then update the imagestream to point to 4.5 and ensure that no errors are in the logs and that a pipeline starts correctly:


## Tag 4.4 jenkins image
$oc tag quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:bd8b955ae1fa10135c9904d85c60b20a8f06deda9f103c88a55e1d28f4cb19cb jenkins:2 --reference-policy='local'

##Create jenkins persistent pod
$oc new-app jenkins-persistent -p NAMESPACE=$( oc project -q) 
## Wait jenkins pod ready
## Tag 4.5 jenkins image
$oc tag  <jenkins-image-in-45> jenkins:2 --reference-policy='local'

## Wait jenkins pod ready

##Create pipeline build
$oc new-app -f ~/go/src/github.com/openshift/origin/examples/jenkins/pipeline/maven-pipeline.yaml
$oc start-build openshift-jee-sample

Comment 2 Jitendar Singh 2020-06-11 12:43:50 UTC
Verified.

Comment 4 errata-xmlrpc 2020-07-13 17:43:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.