Bug 1846078 - Typo in warning: You have used --allow-explicit-upgrade to the update to preceed anyway
Summary: Typo in warning: You have used --allow-explicit-upgrade to the update to prec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.4
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
: 4.6.0
Assignee: Michal Fojtik
QA Contact: To Hung Sze
URL:
Whiteboard:
Depends On:
Blocks: 1876237 1876238
TreeView+ depends on / blocked
 
Reported: 2020-06-10 17:27 UTC by To Hung Sze
Modified: 2020-10-27 16:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1876237 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:06:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift oc pull 468 0 None closed Bug 1846078: fix typo in oc adm upgrade help 2020-10-08 20:34:55 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:06:55 UTC

Description To Hung Sze 2020-06-10 17:27:03 UTC
Description of problem:
The captioned sentence seems to contain a typo.
The word "preceed" probably should be "proceed".
The whole sentence suggested to be:
You have used --allow-explicit-upgrade to update.

Version-Release number of the following components:
rpm -q openshift-ansible - not installed
rpm -q ansible - not installed
ansible --version - not installed

How reproducible:

Steps to Reproduce:
1. Install 4.4.5 using Flexy

2. After 4.4.5 is running, 
oc adm upgrade --to-image=quay.io/openshift-release-dev/ocp-release@sha256:7613d8f7db639147b91b16b54b24cfa351c3cbde6aa7b7bf1b9c80c260efad06

(the image specified above is from "oc adm upgrade" which is currently available to public 4.4.5)

3. While step 2 is in progress, run
oc adm upgrade --to-image=quay.io/openshift-release-dev/ocp-release:4.5.0-rc.1-x86_64 --force --allow-explicit-upgrade=True

Watch for the output
oc adm upgrade --to-image=quay.io/openshift-release-dev/ocp-release:4.5.0-rc.1-x86_64 --force --allow-explicit-upgrade=True
warning: Using by-tag pull specs is dangerous, and while we still allow it in combination with --force for backward compatibility, it would be much safer to pass a by-digest pull spec instead
warning: The requested upgrade image is not one of the available updates.  You have used --allow-explicit-upgrade to the update to preceed anyway
warning: --force overrides cluster verification of your supplied release image and waives any update precondition failures.
error: already upgrading.

  Reason: UpgradePreconditionCheckFailed
  Message: Unable to apply quay.io/openshift-release-dev/ocp-release@sha256:7613d8f7db639147b91b16b54b24cfa351c3cbde6aa7b7bf1b9c80c260efad06: it may not be safe to apply this update



If you want to upgrade anyway, use --allow-upgrade-with-warnings.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:
You have used --allow-explicit-upgrade.
(note the shortening of the sentence plus the period at the end to be consistent with other similar sentence)

Additional info:
code seems to be from here:
https://github.com/openshift/oc/blob/361c30813bf4b85e6b2764ecd8e3435f72484209/pkg/cli/admin/upgrade/upgrade.go#L258

Comment 4 To Hung Sze 2020-06-23 21:04:57 UTC
Checked (linux):
4.5.0.0-0.nightly-2020-06-23-075004 - not fixed

4.6.0-0.nightly-2020-06-23-124328 - fixed
warning: The requested upgrade image is not one of the available updates.  You have used --allow-explicit-upgrade to the update to proceed anyway

Question: what other branch(es) will have this fix?

Comment 5 To Hung Sze 2020-06-24 13:07:20 UTC
Looks like it is meant for 4.6 only. I will close this as verified.

Comment 7 errata-xmlrpc 2020-10-27 16:06:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.