Bug 1876238 - Typo in warning: You have used --allow-explicit-upgrade to the update to preceed anyway
Summary: Typo in warning: You have used --allow-explicit-upgrade to the update to prec...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.5
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
: 4.5.z
Assignee: Michal Fojtik
QA Contact: RamaKasturi
URL:
Whiteboard:
: 1876237 (view as bug list)
Depends On: 1846078
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-06 15:51 UTC by OpenShift BugZilla Robot
Modified: 2020-09-21 17:42 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 17:42:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 557 None closed [release-4.5] Bug 1876238: fix typo in oc adm upgrade help 2020-09-21 14:54:29 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:21 UTC

Comment 1 Micah Abbott 2020-09-06 15:53:00 UTC
*** Bug 1876237 has been marked as a duplicate of this bug. ***

Comment 2 Micah Abbott 2020-09-06 15:53:27 UTC
Saw this typo in `oc` 4.5.7


```
$ oc version
Client Version: 4.5.7
Server Version: 4.5.8
Kubernetes Version: v1.17.1+a1af596

$ oc adm upgrade --allow-explicit-upgrade --to-image quay.io/openshift-release-dev/ocp-release@sha256:ae61753ad8c8a26ed67fa233eea578194600d6c
72622edab2516879cfbf019fd 
warning: The requested upgrade image is not one of the available updates.  You have used --allow-explicit-upgrade to the update to preceed anyway
error: already upgrading.
...
```

Comment 3 Maciej Szulik 2020-09-11 11:40:39 UTC
PR in the queue

Comment 6 RamaKasturi 2020-09-14 10:27:02 UTC
Verified bug in the payload below and i do not see the typo as reported in the bug.

[ramakasturinarra@dhcp35-60 openshift-client-linux-4.5.0-0.nightly-2020-09-12-063044]$ ./oc version
Client Version: 4.5.0-0.nightly-2020-09-12-063044
Server Version: 4.5.0-0.nightly-2020-09-12-063044
Kubernetes Version: v1.18.3+6c42de8

[ramakasturinarra@dhcp35-60 openshift-client-linux-4.5.0-0.nightly-2020-09-12-063044]$ ./oc adm upgrade --to-image=registry.svc.ci.openshift.org/ocp/release:4.5.0-0.nightly-2020-09-12-063044 --force=true --allow-explicit-upgrade=true
warning: Using by-tag pull specs is dangerous, and while we still allow it in combination with --force for backward compatibility, it would be much safer to pass a by-digest pull spec instead
warning: The requested upgrade image is not one of the available updates.  You have used --allow-explicit-upgrade to the update to proceed anyway
warning: --force overrides cluster verification of your supplied release image and waives any update precondition failures.
Updating to release image registry.svc.ci.openshift.org/ocp/release:4.5.0-0.nightly-2020-09-12-063044

Based on the above moving the bug to verified state.

Comment 8 errata-xmlrpc 2020-09-21 17:42:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.