Bug 1846145 - unable to recognize no matches for kind "servicemonitor.monitoring.coreos.com" in version "monitoring.coreos.com/v1"
Summary: unable to recognize no matches for kind "servicemonitor.monitoring.coreos.com...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.5.z
Assignee: Vibhav Bobade
QA Contact: Jitendar Singh
URL:
Whiteboard:
: 1849729 (view as bug list)
Depends On: 1836032
Blocks: 1845495 1865889
TreeView+ depends on / blocked
 
Reported: 2020-06-10 22:08 UTC by OpenShift BugZilla Robot
Modified: 2020-09-04 09:56 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-10 13:50:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 291 None closed [release-4.5] Bug 1846145: Fix Jenkins Monitored templates typo and other updates 2020-09-01 21:05:46 UTC
Red Hat Product Errata RHBA-2020:3188 None None None 2020-08-10 13:50:43 UTC

Comment 1 Akram Ben Aissi 2020-06-11 10:02:47 UTC
Not blocking for 4.5, and the PR for it is on its way, but poor likely to be merged for 4.5, so moving it to 4.5.z
The dependent bz has been set to targeting 4.6.0

Comment 2 Vibhav Bobade 2020-07-10 11:55:59 UTC
*** Bug 1849729 has been marked as a duplicate of this bug. ***

Comment 3 Vibhav Bobade 2020-07-28 18:42:05 UTC
Bumping severity to urgent as customers are not able to use Jenkins Custom CA support.

Comment 6 Jitendar Singh 2020-07-30 13:13:37 UTC
verified
==========================================
jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc process jenkins-persistent-monitored -n openshift | sed 's/" servicemonitor.monitoring.coreos.com"/"ServiceMonitor"/' |  oc create -f -
route.route.openshift.io/jenkins created
persistentvolumeclaim/jenkins created
deploymentconfig.apps.openshift.io/jenkins created
serviceaccount/jenkins created
rolebinding.authorization.openshift.io/jenkins_edit created
service/jenkins-jnlp created
service/jenkins created
servicemonitor.monitoring.coreos.com/jenkins-persistent-monitored created
 jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc get pods
NAME               READY   STATUS    RESTARTS   AGE
jenkins-1-9x8mk    0/1     Pending   0          2s
jenkins-1-deploy   1/1     Running   0          5s
 jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc status
In project jenkins-bug on server https://api.jenkins-4.5-cve-nightly.gcp.devcluster.openshift.com:6443

svc/jenkins-jnlp - 172.30.253.164:50000
https://jenkins-jenkins-bug.apps.jenkins-4.5-cve-nightly.gcp.devcluster.openshift.com (redirects) (svc/jenkins)
  dc/jenkins deploys openshift/jenkins:2 
    deployment #1 running for 23 seconds - 0/1 pods


1 info identified, use 'oc status --suggest' to see details.

jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc get pods
NAME               READY   STATUS    RESTARTS   AGE
jenkins-1-9x8mk    0/1     Running   0          66s
jenkins-1-deploy   1/1     Running   0          69s
 jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc get pods
NAME               READY   STATUS      RESTARTS   AGE
jenkins-1-9x8mk    1/1     Running     0          3m5s
jenkins-1-deploy   0/1     Completed   0          3m8s
 jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc get routes
NAME      HOST/PORT                                                                       PATH   SERVICES   PORT    TERMINATION     WILDCARD
jenkins   jenkins-jenkins-bug.apps.jenkins-4.5-cve-nightly.gcp.devcluster.openshift.com          jenkins    <all>   edge/Redirect   None
 jsingh@localhost  ~/Downloads/openshift-install-linux-4.5.0-0.ci-2020-07-30-024158  oc get pods
NAME               READY   STATUS      RESTARTS   AGE
jenkins-1-9x8mk    1/1     Running     0          9m27s
jenkins-1-deploy   0/1     Completed   0          9m30s
======================================================================
Triggered a new-build and sync also working.

Comment 8 errata-xmlrpc 2020-08-10 13:50:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.5 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3188


Note You need to log in before you can comment on or make changes to this bug.