Bug 1865889 - unable to recognize no matches for kind "servicemonitor.monitoring.coreos.com" in version "monitoring.coreos.com/v1"
Summary: unable to recognize no matches for kind "servicemonitor.monitoring.coreos.com...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Akram Ben Aissi
QA Contact: Jitendar Singh
URL:
Whiteboard:
: 1858214 (view as bug list)
Depends On: 1846145
Blocks: 1852429
TreeView+ depends on / blocked
 
Reported: 2020-08-04 13:15 UTC by Akram Ben Aissi
Modified: 2020-09-22 06:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1836914
Environment:
Last Closed: 2020-09-22 06:58:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-samples-operator pull 294 None closed [release-4.4] Bug 1865889: Fix Jenkins Monitored templates typo and other updates 2020-09-14 09:39:59 UTC
Red Hat Product Errata RHBA-2020:3715 None None None 2020-09-22 06:59:00 UTC

Comment 1 Akram Ben Aissi 2020-08-18 10:03:14 UTC
*** Bug 1858214 has been marked as a duplicate of this bug. ***

Comment 4 Jitendar Singh 2020-09-16 08:37:53 UTC
VERIFIED
===================
 jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates oc create -f jenkins-persistent-monitored.json                          
template.template.openshift.io/jenkins-persistent-monitored created
 jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates  oc process jenkins-persistent-monitored -n jenkins-test1 | oc create -f -
route.route.openshift.io/jenkins created
persistentvolumeclaim/jenkins created
configmap/jenkins-trusted-ca-bundle created
deploymentconfig.apps.openshift.io/jenkins created
serviceaccount/jenkins created
rolebinding.authorization.openshift.io/jenkins_edit created
service/jenkins-jnlp created
service/jenkins created
servicemonitor.monitoring.coreos.com/jenkins-persistent-monitored created
=======================================================================================
 jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates   oc get pods
NAME               READY   STATUS              RESTARTS   AGE
jenkins-1-deploy   1/1     Running             0          26s
jenkins-1-w639b     0/1     ContainerCreating   0          56s
=========================================================================================
jsingh@localhost  ~/go/src/github.com/redhat-developer/jenkins/openshift/templates  oc get pods -w
NAME               READY   STATUS    RESTARTS   AGE
jenkins-1-deploy   1/1     Running   0          4m18s
jenkins-1-w639b    0/1     Running   0          4m49s
jenkins-1-w639b    1/1     Running   0          4m49s
jenkins-1-deploy   0/1     Completed   0          5m19s
jenkins-1-deploy   0/1     Completed   0          5m19s
jenkins-1-deploy   0/1     Completed   0          5m19s

==============================================================================================
created a pipeline build with the image and triggered the build & result SUCCESS.

Comment 6 errata-xmlrpc 2020-09-22 06:58:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3715


Note You need to log in before you can comment on or make changes to this bug.