Bug 1846294 - Engine restart needed after ovirt-register-sso-client-tool
Summary: Engine restart needed after ovirt-register-sso-client-tool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.4.1
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ovirt-4.4.5
: 4.4.5
Assignee: Artur Socha
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-11 10:18 UTC by Yedidyah Bar David
Modified: 2021-05-30 01:56 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.4.5
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-22 10:22:21 UTC
oVirt Team: Infra
pm-rhel: ovirt-4.4+
mtessun: planning_ack+
gdeolive: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 112672 0 master MERGED enginesso: dynamically registered sso clients 2021-01-29 16:52:58 UTC
oVirt gerrit 112700 0 master MERGED enginesso: throttle missing client id calls 2021-01-29 16:53:41 UTC
oVirt gerrit 112745 0 master ABANDONED Revert "packaging: grafana: Restart the engine for SSO" 2021-05-30 01:56:09 UTC

Description Yedidyah Bar David 2020-06-11 10:18:37 UTC
Description of problem:

After registering an SSO client with ovirt-register-sso-client-tool, the engine does not notice this, thus SSO does not work, until the engine is restarted.

Version-Release number of selected component (if applicable):
Current master

How reproducible:
Always

Steps to Reproduce:
1. Install and setup engine on machine A
2. Install and setup DWH+grafana on machine B
3. Login to the engine web ui
4. If bug 1846256 is already fixed, see Additional Info there for creating a user in grafana.
5. Try to login to grafana via SSO

Actual results:
Fails

Expected results:
Works

Additional info:

A workaround is to restart the engine.

Comment 1 Yedidyah Bar David 2020-06-11 10:19:47 UTC
If we decide to postpone fixing this bug, we need to either document that an engine restart is needed, or add code to grafana engine-setup to restart the engine (and probably prompt the user about this).

Comment 2 Yedidyah Bar David 2020-06-15 08:32:57 UTC
(In reply to Yedidyah Bar David from comment #1)
> If we decide to postpone fixing this bug, we need to either document that an
> engine restart is needed, or add code to grafana engine-setup to restart the
> engine (and probably prompt the user about this).

Done in bug 1846870.

Comment 3 Sharon Gratch 2020-07-02 12:23:46 UTC
Please note that engine restart is currently required for displaying the Grafana url on landing page as well: BZ 1846375.

Comment 5 Sandro Bonazzola 2021-03-22 12:57:19 UTC
This bugzilla is included in oVirt 4.4.5 release, published on March 18th 2021.

Since the problem described in this bug report should be resolved in oVirt 4.4.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.