Bug 1846431 - Backport upstream CPU Manager fix 90377
Summary: Backport upstream CPU Manager fix 90377
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Artyom
QA Contact: Weinan Liu
URL:
Whiteboard:
Depends On:
Blocks: 1846453
TreeView+ depends on / blocked
 
Reported: 2020-06-11 15:04 UTC by Victor Pickard
Modified: 2020-10-27 16:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1846453 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:06:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:07:22 UTC

Description Victor Pickard 2020-06-11 15:04:52 UTC
Description of problem:

Backport upstream CPU Manager fix 90377

https://github.com/kubernetes/kubernetes/pull/90377 


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Weinan Liu 2020-06-19 07:21:19 UTC
https://github.com/openshift/origin/pull/25089 is still open

Comment 5 Artyom 2020-07-23 09:57:07 UTC
The fix will be available after the rebase on top of the k8s 1.19, no need to have the separate bug for it.

Comment 6 Scott Dodson 2020-08-04 20:09:10 UTC
(In reply to Artyom from comment #5)
> The fix will be available after the rebase on top of the k8s 1.19, no need
> to have the separate bug for it.

A bug is required if you plan to backport it to 4.5. Moving this bug back to MODIFIED so that it goes ON_QA automatically and the rest of the process happens.

Comment 8 Artyom 2020-08-05 05:21:18 UTC
The PR still not merged.

Comment 9 Artyom 2020-08-05 05:22:36 UTC
I missed that it 4.6 bug, so yes the fix is available after the rebase.

Comment 10 Victor Pickard 2020-08-05 16:29:30 UTC
The fix has been backported, closing this bz.

Comment 11 Victor Pickard 2020-08-05 17:33:53 UTC
Manually verified the code for https://github.com/kubernetes/kubernetes/pull/90377 was picked up in the rebase by visually inspecting relevant files/code in openshift/kubernetes repo on master. Also verified via visual inspection changes are in openshift/origin/vendor/k8s.io/...

Comment 13 errata-xmlrpc 2020-10-27 16:06:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.