Bug 1846459 - DNS LB not allowing UDP traffic after Octavia upgrade
Summary: DNS LB not allowing UDP traffic after Octavia upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Maysa Macedo
QA Contact: GenadiC
URL:
Whiteboard:
Depends On: 1841029
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-11 15:45 UTC by Maysa Macedo
Modified: 2020-07-07 14:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Upon Octavia upgrade from OpenStack 13 to 16, UDP listener is supported and the strategy to enforce DNS resolution over TCP protocol is removed, requiring that the existent DNS service that specifies UDP protocol has the new listener added. Consequence: The already existent DNS load-balancer have an old amphora image which does not support the new listener causing the listener creation to fail. Fix: The DNS OpenShift service that requires UDP is recreated, causing a recreation of the load balancer with the new Amphora version. The recreation of the service and load balancer cause some down time on the DNS resolution. Result: The load balancer for the DNS service is created with all the needed listeners.
Clone Of: 1841029
Environment:
Last Closed: 2020-07-07 14:48:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-network-operator pull 667 None closed Bug 1846459: Recreate DNS service upon Octavia upgrade 2020-09-14 22:45:30 UTC
Red Hat Product Errata RHBA-2020:2805 None None None 2020-07-07 14:48:42 UTC

Comment 3 rlobillo 2020-06-29 16:55:57 UTC
Octavia component update should be part of OSP13 to OSP16 upgrade which is not supported at the moment, so QE verification only confirms that the fix code is present on 4.3.0-0.nightly-2020-06-29-084049.

$ podman pull --authfile secrets.json registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-06-29-084049
$ podman run -it registry.svc.ci.openshift.org/ocp/release:4.3.0-0.nightly-2020-06-29-084049 image cluster-network-operator
quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:97e1523dc72a444a8e429ec988b4cd02ea02b7c217d2c1eb1210b8a408b11b24
$ podman pull --authfile secrets.json quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:97e1523dc72a444a8e429ec988b4cd02ea02b7c217d2c1eb1210b8a408b11b24
Trying to pull quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:97e1523dc72a444a8e429ec988b4cd02ea02b7c217d2c1eb1210b8a408b11b24...
[...]
1a8b056c60a3d319afeeb74e571f58cc522c867732c26e8b80d24d440b015f4d
$ podman inspect 1a8b056c60a3d319afeeb74e571f58cc522c867732c26e8b80d24d440b015f4d | grep commit
                "io.openshift.build.commit.id": "09ec64150aa6fc41d90f63f4552275be4d629a60",
                "io.openshift.build.commit.url": "https://github.com/openshift/cluster-network-operator/commit/09ec64150aa6fc41d90f63f4552275be4d629a60",
            "io.openshift.build.commit.id": "09ec64150aa6fc41d90f63f4552275be4d629a60",
            "io.openshift.build.commit.url": "https://github.com/openshift/cluster-network-operator/commit/09ec64150aa6fc41d90f63f4552275be4d629a60",

Confirmed that HEAD commit of target nightly release is the fix code: https://github.com/openshift/cluster-network-operator/commits/release-4.3

Comment 5 errata-xmlrpc 2020-07-07 14:48:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2805


Note You need to log in before you can comment on or make changes to this bug.