Bug 1847011 - [Kuryr] Pods not getting annotated due to controller missing events
Summary: [Kuryr] Pods not getting annotated due to controller missing events
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Michał Dulko
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks: 1853215
TreeView+ depends on / blocked
 
Reported: 2020-06-15 12:52 UTC by Maysa Macedo
Modified: 2020-10-27 16:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:07:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift kuryr-kubernetes pull 295 0 None closed Bug 1847011: Periodically fetch full list of watched resources 2020-08-18 08:03:42 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:07:38 UTC

Description Maysa Macedo 2020-06-15 12:52:38 UTC
Description of problem:

Under certain scenarios the pods not running on hostNetwork can get stuck on phase ContainerCreating due to missing the kuryr annotation. The addition of the annotation is missed due to the event not being handled by the controller.

Version-Release number of selected component (if applicable):
OCP 4.5
Red Hat OpenStack Platform release 16.1
OVN

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Ben Bennett 2020-06-15 14:31:54 UTC
Setting the target release to the current development branch.  Once a fix has been identified we can work out whether it is safe to backport.

Comment 4 Jon Uriarte 2020-07-16 09:28:18 UTC
Verified in 4.6.0-0.nightly-2020-07-16-005008 on top of OSP 13 2020-07-09.1 puddle.

The OCP cluster with Kuryr was successfully installed 3 times in a row, the clusters are working
without the need to restart the kuryr controller pod.

Comment 6 errata-xmlrpc 2020-10-27 16:07:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.