Bug 1848094 - High number of TX errors on geneve interfaces [coredns misconfiguration]
Summary: High number of TX errors on geneve interfaces [coredns misconfiguration]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 4.5.z
Assignee: Ben Nemec
QA Contact: Nataf Sharabi
URL:
Whiteboard:
: 1852126 (view as bug list)
Depends On: 1841214
Blocks: 1852126
TreeView+ depends on / blocked
 
Reported: 2020-06-17 16:46 UTC by OpenShift BugZilla Robot
Modified: 2020-10-22 21:04 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1852126 1890797 (view as bug list)
Environment:
Last Closed: 2020-10-22 20:59:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift coredns-mdns pull 61 0 None closed [release-4.5] Bug 1848094: Add bind address configuration setting 2021-02-18 19:35:46 UTC
Github openshift coredns pull 32 0 None closed Bug 1848094: Update vendoring of coredns-mdns 2021-02-18 19:35:46 UTC
Github openshift machine-config-operator pull 1879 0 None closed Bug 1848094: [baremetal] Set NonVirtualIP in mdns plugin config 2021-02-18 19:35:45 UTC
Github openshift machine-config-operator pull 2137 0 None closed Bug 1890797: Set NonVirtualIP in mdns plugin config 2021-02-18 19:35:46 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:44:40 UTC

Comment 1 Ben Nemec 2020-06-18 16:07:49 UTC
Until this gets vendored into coredns the code changes aren't done.

Comment 4 Scott Dodson 2020-06-30 12:11:48 UTC
*** Bug 1852126 has been marked as a duplicate of this bug. ***

Comment 5 Miciah Dashiel Butler Masters 2020-07-01 14:46:17 UTC
The fix is in the coredns-mdns plugin, so I'm setting the component to "Networking" with subcomponent "mDNS".

Comment 7 Nataf Sharabi 2020-07-05 11:05:49 UTC
Verified on: 
[kni@provisionhost-0-0 ~]$ oc version
Client Version: 4.5.0-0.nightly-2020-06-05-214616
Server Version: 4.5.0-0.nightly-2020-07-02-190154
Kubernetes Version: v1.18.3+6025c28

*****************************************************
According to Ben Nemec -

The fix is the ip at the end of the mdns line.
*****************************************************

IPV6
[core@master-0-0 ~]$ cat /etc/coredns/Corefile
. {
    errors
    health :18080
    mdns ocp-edge-cluster-0.qe.lab.redhat.com 0 ocp-edge-cluster-0 fd2e:6f44:5dd8::10f
    forward . fe80::5054:ff:fe4b:5b62%bond0 fd2e:6f44:5dd8::1
    cache 30
    reload
    template IN AAAA ocp-edge-cluster-0.qe.lab.redhat.com {
.
.
output omitted

[core@master-0-0 ~]$ ifconfig genev_sys_6081
genev_sys_6081: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 65000
        inet6 fe80::7c66:f0ff:fe6a:e21d  prefixlen 64  scopeid 0x20<link>
        ether 7e:66:f0:6a:e2:1d  txqueuelen 1000  (Ethernet)
        RX packets 127951  bytes 36687078 (34.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 121808  bytes 44083589 (42.0 MiB)
        TX errors 7  dropped 0 overruns 0  carrier 0  collisions 0



IPV4

kni@provisionhost-0-0 clusterconfigs]$ oc version
Client Version: 4.5.0-0.nightly-2020-06-05-214616
Server Version: 4.5.0-0.nightly-2020-07-02-190154
Kubernetes Version: v1.18.3+6025c28
[kni@provisionhost-0-0 clusterconfigs]$

[core@master-0-0 ~]$ cat /etc/coredns/Corefile
. {
    errors
    health :18080
    mdns ocp-edge-cluster-0.qe.lab.redhat.com 0 ocp-edge-cluster-0 192.168.123.127
    forward . 192.168.123.1
.
.
output omitted


[core@master-0-0 ~]$ ifconfig genev_sys_6081
genev_sys_6081: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 65000
        inet6 fe80::a879:55ff:fe36:b53e  prefixlen 64  scopeid 0x20<link>
        ether aa:79:55:36:b5:3e  txqueuelen 1000  (Ethernet)
        RX packets 1146623  bytes 213461945 (203.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1087044  bytes 314429053 (299.8 MiB)
        TX errors 7  dropped 0 overruns 0  carrier 0  collisions 0


Verified!

Comment 8 errata-xmlrpc 2020-07-13 17:44:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409

Comment 9 Ben Nemec 2020-10-01 22:03:03 UTC
Reopening because we've had a request to fix this on the other platforms that use coredns-mdns.


Note You need to log in before you can comment on or make changes to this bug.