Bug 1848418 - Affinity modal closes when user attempts to edit existing rule with [Exists, DoesNotExist] operator
Summary: Affinity modal closes when user attempts to edit existing rule with [Exists, ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.6.0
Assignee: Gilad Lekner
QA Contact: Guohua Ouyang
URL:
Whiteboard:
: 1849932 (view as bug list)
Depends On:
Blocks: 1848425 1852392
TreeView+ depends on / blocked
 
Reported: 2020-06-18 10:52 UTC by Radim Hrazdil
Modified: 2020-10-27 16:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1848425 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:08:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (77.83 KB, image/png)
2020-06-18 10:52 UTC, Radim Hrazdil
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 5771 0 None closed Bug 1848418: Affinity modal closes when user attempts to edit 2020-08-06 18:32:03 UTC
Github openshift console pull 5820 0 None closed Bug 1848418: Affinity modal closes when user attempts to edit 2020-08-06 18:32:03 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:08:39 UTC

Description Radim Hrazdil 2020-06-18 10:52:03 UTC
Created attachment 1697940 [details]
screenshot

Description of problem:

When an affinity rule is added with Exists or DoesNotExist operators, the affinity modal closes when user tries to edit such rule.
Error in terminal:
Uncaught error Uncaught TypeError: Cannot read property 'map' of undefined


Version-Release number of selected component (if applicable):
console/release-4.5 and console/master
OCP 4.4.5
CNV 2.3


How reproducible:
100%

Steps to Reproduce:
1. Add affinity rule with node selector 'test' and operator DoesNotExist
2. Save, Save
3. Open Affinity modal dialog and try to edit the affinity rule

Actual results:
Affinity modal is closed

Expected results:


Additional info:

Comment 3 Radim Hrazdil 2020-06-24 08:54:54 UTC
I'm getting 
An error occurred
Error "spec.template.spec.affinity in body must be of type object: "null"" for field "undefined".

on attempt to delete an affinity rule

Comment 4 Yaacov Zamir 2020-06-24 09:06:12 UTC
*** Bug 1849932 has been marked as a duplicate of this bug. ***

Comment 6 Guohua Ouyang 2020-06-30 10:18:55 UTC
verified on upstream 4.6 branch

Comment 8 errata-xmlrpc 2020-10-27 16:08:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.