Bug 1849932 - Cannot delete affinity rules on UI
Summary: Cannot delete affinity rules on UI
Keywords:
Status: CLOSED DUPLICATE of bug 1848418
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Tomas Jelinek
QA Contact: Guohua Ouyang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-23 08:32 UTC by Guohua Ouyang
Modified: 2021-01-02 19:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-24 09:06:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
error of delete affinity rules (165.07 KB, image/png)
2020-06-23 08:32 UTC, Guohua Ouyang
no flags Details
works on my build (608.15 KB, image/gif)
2020-06-24 08:24 UTC, Yaacov Zamir
no flags Details

Description Guohua Ouyang 2020-06-23 08:32:21 UTC
Created attachment 1698405 [details]
error of delete affinity rules

Description of problem:
An error occurs when delete affinity rules on UI:

Error "spec.template.spec.affinity in body must be of type object: "null"" for field "undefined"."

Version-Release number of selected component (if applicable):
4.5.0-rc.2

How reproducible:
100%

Steps to Reproduce:
1. Create a VM
2. Add a affinity rule and save it
3. Reopen affinity modal and try to delete it

Actual results:


Expected results:


Additional info:

Comment 1 Yaacov Zamir 2020-06-23 10:47:04 UTC
@Gilad hi, do you think this BZ related to:
https://bugzilla.redhat.com/show_bug.cgi?id=1848425

Comment 2 Yaacov Zamir 2020-06-24 07:20:38 UTC
moving to modified:

a - can't duplicate on current master
b - I think it was fixed by 1848425

Comment 3 Guohua Ouyang 2020-06-24 07:56:50 UTC
I can reproduce it on master. You have to reopen the modal, delete it and save, then the error shows.

Comment 4 Yaacov Zamir 2020-06-24 08:24:43 UTC
Created attachment 1698544 [details]
works on my build

Comment 5 Yaacov Zamir 2020-06-24 08:26:26 UTC
Guohua hi,

I attached my test, can you look if I'm doing it correctly ?

Comment 8 Yaacov Zamir 2020-06-24 09:06:12 UTC

*** This bug has been marked as a duplicate of bug 1848418 ***

Comment 9 Gilad Lekner 2021-01-02 19:26:24 UTC
Clearing redundant NEEDINFO


Note You need to log in before you can comment on or make changes to this bug.