Bug 18495 - xmessage doesn't display the message
Summary: xmessage doesn't display the message
Status: CLOSED DUPLICATE of bug 18982
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-06 04:51 UTC by Terry Griffin
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 17:42:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of xmessage working. (37.08 KB, image/jpeg)
2001-03-23 09:20 UTC, Mike A. Harris
no flags Details

Description Terry Griffin 2000-10-06 04:51:56 UTC
If you run this command:

	xmessage "this is a test"

You don't see the message "this is a test". You instead get an empty widget
where the text is supposed to be. The "Okay" button comes out fine however.

This does not appear to be an X resource problem with fg/bg colors. Trying
various combinations of xmessage on RH 6.2 and RH 7 with X servers on RH
6.2 and RH 7 I narrowed the problem to xmessage on RH 7 and not a problem
with the X server or its resource settings.

Comment 1 daniel.deimert 2000-10-06 16:01:25 UTC
Try enlarging the window.  It seems that xmessage doesn't draw or clips the
message if the window is too small, and it sets the default size to something
which is too small.


Comment 2 Terry Griffin 2000-10-07 01:53:57 UTC
Yup - sizing is the problem. If I increase the vertical size then the text
appears. In the man page it says "Unless a size is specified, xmessage sizes
itself to fit the message, up to a maximum size." So something broke in this
auto-sizing between RH 6.2 and RH 7.  I tried it with a couple of different
window managers just to make sure that the WM wasn't overriding the
application's requested size. The choice of WM had no effect. Anyway now I have
my workaround and my original priority setting of "low" stands!


Comment 3 Alan Cox 2000-10-14 22:40:16 UTC
This appears to be a bug in Xaw.  A problem has come up in the Xaw widget set
form resizing which looks suspiciously relevant.


Comment 4 Mike A. Harris 2001-03-23 09:15:06 UTC

*** This bug has been marked as a duplicate of 18982 ***

Comment 5 Mike A. Harris 2001-03-23 09:20:36 UTC
Created attachment 13409 [details]
Screenshot of xmessage working.

Comment 6 Mike A. Harris 2001-03-23 09:21:35 UTC
The above screenshot is from XFree86 4.0.3 in rawhide.  She be workin.


Note You need to log in before you can comment on or make changes to this bug.