Bug 1849538 - duplicate error message can not be compressed for kubeletconfig
Summary: duplicate error message can not be compressed for kubeletconfig
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.6.0
Assignee: Ryan Phillips
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On:
Blocks: 1849817
TreeView+ depends on / blocked
 
Reported: 2020-06-22 07:33 UTC by MinLi
Modified: 2021-01-13 20:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:08:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1859 0 None closed Bug 1849538: kubelet: wait to requeue after mcp error 2021-02-01 09:51:20 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:09:01 UTC

Description MinLi 2020-06-22 07:33:05 UTC
Description of problem:
duplicate error message can not be compressed for kubeletconfig

Version-Release number of selected component (if applicable):
$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-06-19-024326   True        False         110m    Cluster version is 4.5.0-0.nightly-2020-06-19-024326


How reproducible:
always

Steps to Reproduce:
1.create a kubeletconfig without matching-label mcp
2.$ oc get kubeletconfig -o yaml
3.

Actual results:
2.$ oc get kubeletconfig -o yaml 
apiVersion: v1
items:
- apiVersion: machineconfiguration.openshift.io/v1
  kind: KubeletConfig
  metadata:
    creationTimestamp: "2020-06-19T06:34:59Z"
    finalizers:
    - 05ebf7c4-63a1-4255-a465-ceca43ae344c
    generation: 1
    managedFields:
...
    name: custom-kubelet-performance
    resourceVersion: "48910"
    selfLink: /apis/machineconfiguration.openshift.io/v1/kubeletconfigs/custom-kubelet-performance
    uid: 2dbf1821-1f4a-40c2-a8aa-6e26ce7aa9b8
  spec:
    kubeletConfig:
      maxPods: 220
    machineConfigPoolSelector:
      matchLabels:
        custom-kubelet: max-pods
  status:
    conditions:
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure



Expected results:
2.duplicate error message should be compressed

Additional info:

Comment 3 MinLi 2020-06-24 03:33:18 UTC
verified with version : 4.6.0-0.nightly-2020-06-23-220540

Comment 5 errata-xmlrpc 2020-10-27 16:08:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196

Comment 6 Qi Wang 2021-01-13 20:11:22 UTC
*** Bug 1904133 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.