Bug 1849817 - [4.5]duplicate error message can not be compressed for kubeletconfig
Summary: [4.5]duplicate error message can not be compressed for kubeletconfig
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: Seth Jennings
QA Contact: MinLi
URL:
Whiteboard:
Depends On: 1849538
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-06-22 21:14 UTC by OpenShift BugZilla Robot
Modified: 2020-08-24 15:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-24 15:13:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift machine-config-operator pull 1861 0 None closed [release-4.5] Bug 1849817: kubelet: wait to requeue after mcp error 2021-02-04 03:36:34 UTC
Red Hat Product Errata RHBA-2020:3436 0 None None None 2020-08-24 15:14:08 UTC

Description OpenShift BugZilla Robot 2020-06-22 21:14:10 UTC
+++ This bug was initially created as a clone of Bug #1849538 +++

Description of problem:
duplicate error message can not be compressed for kubeletconfig

Version-Release number of selected component (if applicable):
$ oc get clusterversion 
NAME      VERSION                             AVAILABLE   PROGRESSING   SINCE   STATUS
version   4.5.0-0.nightly-2020-06-19-024326   True        False         110m    Cluster version is 4.5.0-0.nightly-2020-06-19-024326


How reproducible:
always

Steps to Reproduce:
1.create a kubeletconfig without matching-label mcp
2.$ oc get kubeletconfig -o yaml
3.

Actual results:
2.$ oc get kubeletconfig -o yaml 
apiVersion: v1
items:
- apiVersion: machineconfiguration.openshift.io/v1
  kind: KubeletConfig
  metadata:
    creationTimestamp: "2020-06-19T06:34:59Z"
    finalizers:
    - 05ebf7c4-63a1-4255-a465-ceca43ae344c
    generation: 1
    managedFields:
...
    name: custom-kubelet-performance
    resourceVersion: "48910"
    selfLink: /apis/machineconfiguration.openshift.io/v1/kubeletconfigs/custom-kubelet-performance
    uid: 2dbf1821-1f4a-40c2-a8aa-6e26ce7aa9b8
  spec:
    kubeletConfig:
      maxPods: 220
    machineConfigPoolSelector:
      matchLabels:
        custom-kubelet: max-pods
  status:
    conditions:
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-06-19T06:34:59Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure



Expected results:
2.duplicate error message should be compressed

Additional info:

Comment 3 MinLi 2020-08-03 09:50:28 UTC
not fix in version : 4.5.0-0.nightly-2020-08-01-204100

  status:
    conditions:
    - lastTransitionTime: "2020-08-03T07:57:50Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-08-03T07:57:50Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure
    - lastTransitionTime: "2020-08-03T07:57:50Z"
      message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
      status: "False"
      type: Failure

Comment 5 Seth Jennings 2020-08-10 16:06:08 UTC
Ryan is on leave

Comment 6 Seth Jennings 2020-08-10 20:37:58 UTC
PR merged but bot missed it

Comment 9 MinLi 2020-08-13 06:50:22 UTC
fixed in version: 4.5.0-0.nightly-2020-08-12-191533

status:
  conditions:
  - lastTransitionTime: "2020-08-13T06:42:45Z"
    message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
    status: "False"
    type: Failure
  - lastTransitionTime: "2020-08-13T06:43:45Z"
    message: 'Error: could not find any MachineConfigPool set for KubeletConfig'
    status: "False"
    type: Failure

Comment 11 errata-xmlrpc 2020-08-24 15:13:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.7 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3436


Note You need to log in before you can comment on or make changes to this bug.